aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-13 23:15:00 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-07 13:05:02 +0000
commit8ae9b5900336c28cebdb3e13154a20f58d8bae19 (patch)
tree40548b7f60b0d72c17440a71f0b275979e8a3722
parent9a9a6709c239355345e9718c35bbfb9d5c8467d5 (diff)
testing/setroot: modernize abuild
-rw-r--r--testing/setroot/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/testing/setroot/APKBUILD b/testing/setroot/APKBUILD
index 2cf1a70c51d..97570e7992a 100644
--- a/testing/setroot/APKBUILD
+++ b/testing/setroot/APKBUILD
@@ -10,21 +10,18 @@ license="GPL3"
depends=""
depends_dev="imlib2-dev"
makedepends="$depends_dev"
-install=""
subpackages="$pkgname-doc"
-source="saveas-https://github.com/ttzhou/$pkgname/archive/v$pkgver.tar.gz/$pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ttzhou/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- make || return 1
+ make
}
package() {
cd "$builddir"
- make PREFIX=/usr DESTDIR="$pkgdir" install || return 1
+ make PREFIX=/usr DESTDIR="$pkgdir" install
}
-md5sums="99f58d6fe8026c05e6eb63be04d45a54 setroot-2.0.tar.gz"
-sha256sums="c4ccdacb44a7b15d3c592d4b94a64543c98acf3264abf279e0c4970189806fa9 setroot-2.0.tar.gz"
sha512sums="0e1d0aa2a002ce348d2c4791e27980f1431ed9543d46dcbc1f8d20b1518d126c5cd9d4642aec5f13c8ab0c7b3e75d55e5f70a5b649264949989965505dfedb71 setroot-2.0.tar.gz"