aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-23 10:52:27 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-23 10:52:27 +0000
commitbb160bb259b96da87176aa01213e1a75306069ae (patch)
tree24006feb1e93bf5de2f2247c181efba6556c442a
parentbf9d181f3de29031973b61ebea07586c3139588c (diff)
community/py-greenlet: moved from testing, added python3 support, added py2/py3 subpackages
-rw-r--r--community/py-greenlet/APKBUILD (renamed from testing/py-greenlet/APKBUILD)47
-rw-r--r--community/py-greenlet/gcc-4.8-bugfix.patch (renamed from testing/py-greenlet/gcc-4.8-bugfix.patch)0
2 files changed, 29 insertions, 18 deletions
diff --git a/testing/py-greenlet/APKBUILD b/community/py-greenlet/APKBUILD
index 8b6af4a6765..b60688fda42 100644
--- a/testing/py-greenlet/APKBUILD
+++ b/community/py-greenlet/APKBUILD
@@ -3,37 +3,48 @@
pkgname=py-greenlet
_pkgname=greenlet
pkgver=0.4.10
-pkgrel=0
+pkgrel=1
pkgdesc="Lightweight in-process concurrent programming"
url="http://pypi.python.org/pypi/greenlet"
-arch="all"
+arch="noarch"
license="MIT"
depends=""
-makedepends="python-dev py-setuptools"
+makedepends="python2-dev py-setuptools python3-dev"
+subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- env
- CFLAGS="-O0" CPPFLAGS="-O0" CXXFLAGS="-O0" python setup.py build || return 1
+ cd "$builddir"
+ export CFLAGS="-O0" CPPFLAGS="-O0" CXXFLAGS="-O0"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
- cd "$_builddir"
- python setup.py install --root="$pkgdir" || return 1
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ arch="all"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+}
+
+_py3() {
+ _py python3
}
+
md5sums="bed0c4b3b896702131f4d5c72f87c41d greenlet-0.4.10.zip"
sha256sums="9a98d49f63259b16d3627976b69dd856888a376c498b091c8e9ead56d5098ca8 greenlet-0.4.10.zip"
sha512sums="7fc78b14dca079f838647fd99878850cf9e83af781c985362146a11f71c5a700fbac8148273cd1c0ec4ac6ead4cf5bd389e001b8fc1225e87e9b51919d7ecc6c greenlet-0.4.10.zip"
diff --git a/testing/py-greenlet/gcc-4.8-bugfix.patch b/community/py-greenlet/gcc-4.8-bugfix.patch
index 1526f3eb186..1526f3eb186 100644
--- a/testing/py-greenlet/gcc-4.8-bugfix.patch
+++ b/community/py-greenlet/gcc-4.8-bugfix.patch