aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoropal hart <opal@wowana.me>2021-12-14 12:29:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2022-06-27 07:29:07 +0000
commitd7a8392a27555c4f744fed1778cce3e15afa7bdb (patch)
tree9aa4653ca0a6183d64b2d61b80ffbfd44e3cbff2
parent4bf5dd700b84420fc5020d7c2db1d285a8021bf4 (diff)
main/dhcpcd: fix rundir and pidfilepatches/3808
dhcpcd does not write a pidfile to /run/dhcpcd.pid; this may have been true in the past, but now it directly writes files (pid, sock, ...) to the configured rundir. Configure with --rundir=/run/dhcpcd as Gentoo ebuild for net-misc/dhcpcd does, and direct the initscript to /run/dhcpcd/pid for pidfile.
-rw-r--r--main/dhcpcd/APKBUILD4
-rw-r--r--main/dhcpcd/dhcpcd.initd2
2 files changed, 3 insertions, 3 deletions
diff --git a/main/dhcpcd/APKBUILD b/main/dhcpcd/APKBUILD
index 269a068ca94..3a7d18d1b1e 100644
--- a/main/dhcpcd/APKBUILD
+++ b/main/dhcpcd/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dhcpcd
pkgver=9.4.1
-pkgrel=0
+pkgrel=1
pkgdesc="RFC2131 compliant DHCP client"
url="https://roy.marples.name/projects/dhcpcd"
arch="all"
@@ -26,7 +26,7 @@ build() {
--localstatedir=/var \
--libexecdir=/usr/lib/$pkgname \
--dbdir=/var/lib/$pkgname \
- --rundir=/run \
+ --rundir=/run/dhcpcd \
--enable-ipv6 \
--without-dev \
--without-udev
diff --git a/main/dhcpcd/dhcpcd.initd b/main/dhcpcd/dhcpcd.initd
index aab118242e1..217d03ee212 100644
--- a/main/dhcpcd/dhcpcd.initd
+++ b/main/dhcpcd/dhcpcd.initd
@@ -5,7 +5,7 @@ description="DHCP Client Daemon"
command="/sbin/dhcpcd"
command_args="-q ${command_args:-}"
command_args_foreground="-B"
-pidfile="/run/dhcpcd.pid"
+pidfile="/run/dhcpcd/pid"
depend() {
provide net