summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2016-02-22 12:56:28 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-02-23 07:45:54 +0000
commitae6d8820a00d31809716682b979d96a2f76361a5 (patch)
tree5f5c693b1569567ea59882180d3b3728e0f25f95
parent60d81d4e9c540f8fe9819d63850372b456a36a6f (diff)
testing/php7: fix mysqli, mysqlnd and pdo_mysql extensions
- mysqli and pdo_mysql now uses system libmysqlclient library - mysqlnd now has mysqli as a backend - fixes #5111
-rw-r--r--testing/php7/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/php7/APKBUILD b/testing/php7/APKBUILD
index 72e889c474b..d3c3076ae5c 100644
--- a/testing/php7/APKBUILD
+++ b/testing/php7/APKBUILD
@@ -3,7 +3,7 @@
pkgname=php7
_pkgreal=php
pkgver=7.0.3
-pkgrel=0
+pkgrel=1
pkgdesc="The PHP language runtime engine - 7th branch"
url="http://www.php.net/"
arch="x86_64 armhf"
@@ -148,7 +148,8 @@ _build() {
--with-mcrypt=shared \
--with-sqlite3=shared --with-pdo-sqlite=shared \
--with-pdo-dblib=shared \
- --with-mysqli=shared,mysqlnd --enable-mysqlnd=shared --with-pdo-mysql=shared --with-mysql-sock=/run/mysqld/mysqld.sock \
+ --with-mysqli=shared,/usr/bin/mysql_config \
+ --enable-mysqlnd=shared --with-pdo-mysql=shared,/usr/bin/mysql_config --with-mysql-sock=/run/mysqld/mysqld.sock \
--with-pgsql=shared --with-pdo-pgsql=shared \
--with-unixODBC=shared,/usr -with-pdo-odbc=shared,unixODBC,/usr \
--with-dbmaker=shared \
@@ -356,7 +357,7 @@ ldap() { _mv_ext ldap; }
mbstring() { _mv_ext mbstring; }
mcrypt() { _mv_ext mcrypt; }
mysqli() { _mv_ext mysqli; }
-mysqlnd() { _mv_ext mysqlnd; }
+mysqlnd() { _mv_ext mysqlnd $pkgname-mysqli; }
odbc() { _mv_ext odbc; }
opcache() { _mv_ext opcache; }
openssl() { _mv_ext openssl; }