summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2010-11-04 15:00:35 +0200
committerTimo Teräs <timo.teras@iki.fi>2010-11-05 09:11:06 +0200
commit6708e8870584ff77c2bcf0bad81a8bd0d34eb7d1 (patch)
tree2f1b775a96bd6d7c344d1e7375f7d66a5265d9bb
parenta0601e3759919e432c7edb59d15989f59556024e (diff)
main/opennhrp: holding-time fix from upstream
(cherry picked from commit 286c5b85d334287f5b7441cdd86540f3ce8b9afa)
-rw-r--r--main/opennhrp/APKBUILD4
-rw-r--r--main/opennhrp/fix-holding-time.patch31
2 files changed, 34 insertions, 1 deletions
diff --git a/main/opennhrp/APKBUILD b/main/opennhrp/APKBUILD
index bd4b40d3bc9..ee0ce82465d 100644
--- a/main/opennhrp/APKBUILD
+++ b/main/opennhrp/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=opennhrp
pkgver=0.12
-pkgrel=0
+pkgrel=1
pkgdesc="NBMA Next Hop Resolution Protocol daemon"
url="http://sourceforge.net/projects/opennhrp"
license="GPL-3"
@@ -10,6 +10,7 @@ makedepends="c-ares-dev"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
opennhrp-0.9.3-peer-up-bgp.patch
+ fix-holding-time.patch
$pkgname.initd
$pkgname.confd
"
@@ -33,5 +34,6 @@ package() {
}
md5sums="864e4253a0673bb6dcd6dd60ae5d69df opennhrp-0.12.tar.bz2
f81539fc92800bb79668dda119a97d1d opennhrp-0.9.3-peer-up-bgp.patch
+87a9fce5fb62beeae927d4216e341ea1 fix-holding-time.patch
ae65f88ccf849ef882669a8b4f0c7fc0 opennhrp.initd
8eee86233728dc0d156bbfee6d98f338 opennhrp.confd"
diff --git a/main/opennhrp/fix-holding-time.patch b/main/opennhrp/fix-holding-time.patch
new file mode 100644
index 00000000000..3aee17dc05b
--- /dev/null
+++ b/main/opennhrp/fix-holding-time.patch
@@ -0,0 +1,31 @@
+From: Timo Teräs <timo.teras@iki.fi>
+Date: Wed, 3 Nov 2010 07:03:53 +0000 (+0200)
+Subject: config: fix holding-time to apply to shortcut-target
+X-Git-Url: http://opennhrp.git.sourceforge.net/git/gitweb.cgi?p=opennhrp%2Fopennhrp;a=commitdiff_plain;h=94d1a7d;hp=f9b92c4dcb162670c5cd2226b40e0446c9d3c63a
+
+config: fix holding-time to apply to shortcut-target
+
+Fix the order of object checks to make the keyword apply
+to shortcut-target if in such context, and only after that
+to interface context.
+---
+
+diff --git a/nhrp/opennhrp.c b/nhrp/opennhrp.c
+index 053de99..f2ecd44 100644
+--- a/nhrp/opennhrp.c
++++ b/nhrp/opennhrp.c
+@@ -245,11 +245,11 @@ static int load_config(const char *config_file)
+ } else if (strcmp(word, "holding-time") == 0) {
+ peer = NULL;
+ read_word(in, &lineno, sizeof(word), word);
+- if (iface != NULL)
+- iface->holding_time = atoi(word);
+- else if (peer != NULL &&
++ if (peer != NULL &&
+ peer->type == NHRP_PEER_TYPE_LOCAL_ADDR)
+ peer->holding_time = atoi(word);
++ else if (iface != NULL)
++ iface->holding_time = atoi(word);
+ else
+ rc = 7;
+ } else if (strcmp(word, "cisco-authentication") == 0) {