summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-11-24 10:59:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-24 11:00:22 +0000
commit1606d6d9c5150b883b939a54df3a5686643609a1 (patch)
treebb8487c9bbce10ab360011ae29479a965e0fc1b1
parent6fa4a2cd70c074adcbc9852c3598a972beb9d64b (diff)
x11/cups: upgrade to 1.4.2
-rw-r--r--x11/cups/APKBUILD16
-rw-r--r--x11/cups/cups-1.4.0-backend-https.patch11
-rw-r--r--x11/cups/cups-1.4.1-usb-function-decl.patch25
3 files changed, 7 insertions, 45 deletions
diff --git a/x11/cups/APKBUILD b/x11/cups/APKBUILD
index 23cdc9987fc..ccb9632b344 100644
--- a/x11/cups/APKBUILD
+++ b/x11/cups/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cups
-pkgver=1.4.1
+pkgver=1.4.2
pkgrel=0
pkgdesc="The CUPS Printing System"
url="http://www.cups.org/"
@@ -14,15 +14,11 @@ pkgusers="lp"
source="ftp://ftp.easysw.com/pub/$pkgname/$pkgver/$pkgname-$pkgver-source.tar.bz2
$pkgname.logrotate
cupsd.initd
- cups-1.4.0-backend-https.patch
- cups-1.4.1-usb-function-decl.patch
"
build ()
{
cd "$srcdir"/$pkgname-$pkgver
- patch -p1 -i ../cups-1.4.0-backend-https.patch || return 1
- patch -p1 -i ../cups-1.4.1-usb-function-decl.patch || return 1
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -46,6 +42,10 @@ build ()
--with-pdftops=pdftops \
--with-optim="$CFLAGS"
make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make BUILDROOT="$pkgdir" install
rm -rf "$pkgdir"/etc/init.d "$pkgdir"/etc/rc*
@@ -87,8 +87,6 @@ client() {
touch "$subpkgdir"/usr/share/cups/charmaps/us-ascii.txt
}
-md5sums="587a58039c112ecb3c932e048c8a7b01 cups-1.4.1-source.tar.bz2
+md5sums="d95e2d588e3d36e563027a963b117b1b cups-1.4.2-source.tar.bz2
f861b18f4446c43918c8643dcbbd7f6d cups.logrotate
-a1fb32d0f7745bada3c45acbf883bd93 cupsd.initd
-8ed5e69e85abf6c5f1a2068c679392e2 cups-1.4.0-backend-https.patch
-53da7d8c4cb35986ac0ebacb92d072f8 cups-1.4.1-usb-function-decl.patch"
+a1fb32d0f7745bada3c45acbf883bd93 cupsd.initd"
diff --git a/x11/cups/cups-1.4.0-backend-https.patch b/x11/cups/cups-1.4.0-backend-https.patch
deleted file mode 100644
index 8a70a20e6c5..00000000000
--- a/x11/cups/cups-1.4.0-backend-https.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur cups-1.4.0/backend/Makefile cups-1.4.0.new/backend/Makefile
---- cups-1.4.0/backend/Makefile 2009-03-03 20:39:21.000000000 +0100
-+++ cups-1.4.0.new/backend/Makefile 2009-09-01 14:00:05.592615359 +0200
-@@ -91,6 +91,7 @@
- done
- $(RM) $(SERVERBIN)/backend/http
- $(LN) ipp $(SERVERBIN)/backend/http
-+ $(LN) ipp $(SERVERBIN)/backend/https
- if test "x$(DNSSD_BACKEND)" != x; then \
- $(RM) $(SERVERBIN)/backend/mdns; \
- $(LN) $(DNSSD_BACKEND) $(SERVERBIN)/backend/mdns; \
diff --git a/x11/cups/cups-1.4.1-usb-function-decl.patch b/x11/cups/cups-1.4.1-usb-function-decl.patch
deleted file mode 100644
index 3953d92f86d..00000000000
--- a/x11/cups/cups-1.4.1-usb-function-decl.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 484851e02cc5a9b702e0f226f20a0d33325d9dee Mon Sep 17 00:00:00 2001
-From: Tim Waugh <twaugh@redhat.com>
-Date: Mon, 14 Sep 2009 17:34:36 +0100
-Subject: [PATCH] Fixed side_cb function declaration in usb-unix.c.
-
----
- backend/usb-unix.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/backend/usb-unix.c b/backend/usb-unix.c
-index c47910d..a00f1ad 100644
---- a/backend/usb-unix.c
-+++ b/backend/usb-unix.c
-@@ -560,7 +560,7 @@ open_device(const char *uri, /* I - Device URI */
- * 'side_cb()' - Handle side-channel requests...
- */
-
--static void
-+static int
- side_cb(int print_fd, /* I - Print file */
- int device_fd, /* I - Device file */
- int snmp_fd, /* I - SNMP socket (unused) */
---
-1.6.4.2
-