summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-11-04 14:41:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-11-04 14:41:04 +0000
commit5f11f909dbb20c7d4b7a530027bdb2cc43f15055 (patch)
tree252292c6072a0e3aec469709821afb19b76cb408
parenteec0548cff45a33465918f52ec257d7f1c0754ce (diff)
patch for fakeroot so we dont get ugly output from getopt
-rw-r--r--core/fakeroot/APKBUILD5
-rw-r--r--core/fakeroot/getopt.patch11
2 files changed, 15 insertions, 1 deletions
diff --git a/core/fakeroot/APKBUILD b/core/fakeroot/APKBUILD
index c2f8607e86c..f08e5d0c1ea 100644
--- a/core/fakeroot/APKBUILD
+++ b/core/fakeroot/APKBUILD
@@ -6,10 +6,13 @@ license='GPL'
url="http://packages.debian.org/fakeroot"
depends='uclibc'
makedepends='binutils gcc make linux-headers uclibc-dev'
-source=http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.tar.gz
+subpackages="dev doc"
+source="http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.tar.gz
+ getopt.patch"
build() {
cd $startdir/src/$pkgname-$pkgver
+ patch -p1 < ../getopt.patch
./configure --prefix=/usr #--libdir=/usr/lib/libfakeroot
make || return 1
make DESTDIR=$startdir/pkg install
diff --git a/core/fakeroot/getopt.patch b/core/fakeroot/getopt.patch
new file mode 100644
index 00000000000..177e1ba9549
--- /dev/null
+++ b/core/fakeroot/getopt.patch
@@ -0,0 +1,11 @@
+--- fakeroot-1.10.1/scripts/fakeroot.in.orig Tue Nov 4 14:32:03 2008
++++ fakeroot-1.10.1/scripts/fakeroot.in Tue Nov 4 14:32:16 2008
+@@ -28,7 +28,7 @@
+
+ libfound=no
+
+-GETOPTEST=`getopt --version`
++GETOPTEST=`getopt --version 2>/dev/null`
+ case $GETOPTEST in
+ getopt*) # GNU getopt
+ TEMP=`getopt -l lib: -l faked: -l unknown-is-real -l fd-base: -l version -l help -- +l:f:i:s:ub:vh "$@"`