summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-24 01:18:36 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-07 05:43:59 -0300
commit2bfc98b40fe11892453d10e77693282bbe7a56e3 (patch)
tree9624feadcb5cd2449f6d26178568c62b3a6e1992
parent3b0304ade99d77706dfb5b067e6ce7c23aa8e023 (diff)
testing/jsonrpc-glib: new aport
-rw-r--r--testing/jsonrpc-glib/APKBUILD33
-rw-r--r--testing/jsonrpc-glib/disable-flaky-test.patch19
2 files changed, 52 insertions, 0 deletions
diff --git a/testing/jsonrpc-glib/APKBUILD b/testing/jsonrpc-glib/APKBUILD
new file mode 100644
index 00000000000..102eb702021
--- /dev/null
+++ b/testing/jsonrpc-glib/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=jsonrpc-glib
+pkgver=3.32.0
+pkgrel=0
+pkgdesc="Library to communicate using the JSON-RPC 2.0 specification"
+url="https://gitlab.gnome.org/GNOME/jsonrpc-glib"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="gtk+3.0-dev vala gobject-introspection-dev gtk-doc meson json-glib-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/jsonrpc-glib/${pkgver%.*}/jsonrpc-glib-$pkgver.tar.xz
+ disable-flaky-test.patch"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --buildtype=release \
+ -Denable_gtk_doc=true \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="c6c52d36d3f8f736bc07c50174ca4a50e3cde6b23928751f260b4482e15cda9726b8279228653e4fde114111592131f344f3c7cf820edcc680fb0b32f9089ea5 jsonrpc-glib-3.32.0.tar.xz
+ec2eea185a86c6ac16fc51c7d67faca7805c69e6127f1288d551ba7249f898672a5a4ef1f2d05531f65e5d5087d4d576b251f3330806809bdeab6abd6593dc34 disable-flaky-test.patch"
diff --git a/testing/jsonrpc-glib/disable-flaky-test.patch b/testing/jsonrpc-glib/disable-flaky-test.patch
new file mode 100644
index 00000000000..6659289e3bc
--- /dev/null
+++ b/testing/jsonrpc-glib/disable-flaky-test.patch
@@ -0,0 +1,19 @@
+See https://gitlab.gnome.org/GNOME/jsonrpc-glib/issues/2
+diff --git a/tests/meson.build b/tests/meson.build
+index 40b410b..3318c79 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -38,13 +38,6 @@ test_server = executable('test-server', 'test-server.c',
+ )
+ test('test-server', test_server, env: test_env)
+
+-test_stress = executable('test-stress', 'test-stress.c',
+- c_args: test_cflags,
+- link_args: test_link_args,
+- dependencies: test_deps,
+-)
+-test('test-stress', test_stress, env: test_env)
+-
+ test_gauntlet = executable('test-gauntlet', 'test-gauntlet.c',
+ c_args: test_cflags,
+ link_args: test_link_args,