summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-17 12:37:21 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-17 15:09:03 -0300
commit6bf412c8743da36bc7b8bdabb04947586f8b223e (patch)
tree5cb0bca9d933847aaef6073590b162442d2b8ec6
parent0ac585f438686c5c720343fd8b019ed86d905bf2 (diff)
testing/gnome-builder: upgrade to 3.32.3
-rw-r--r--testing/gnome-builder/APKBUILD14
-rw-r--r--testing/gnome-builder/fix-appdata.patch38
-rw-r--r--testing/gnome-builder/fix-musl.patch13
-rw-r--r--testing/gnome-builder/musl-wordsize.patch41
4 files changed, 19 insertions, 87 deletions
diff --git a/testing/gnome-builder/APKBUILD b/testing/gnome-builder/APKBUILD
index ddd1792f7d2..f8d43bbf041 100644
--- a/testing/gnome-builder/APKBUILD
+++ b/testing/gnome-builder/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-builder
-pkgver=3.30.3
+pkgver=3.32.3
pkgrel=0
pkgdesc="Develop software for GNOME"
url="https://wiki.gnome.org/Apps/Builder"
-arch="all !aarch64 !s390x" # Lots of tests SIGSEV on aarch64
+arch="all !s390x" # Lots of tests SIGSEV on aarch64
license="GPL-3.0-or-later"
depends="devhelp flatpak-builder py3-lxml py3-gobject3"
makedepends="meson libdazzle-dev glib-dev gtk+3.0-dev gtksourceview4-dev
@@ -13,12 +13,11 @@ makedepends="meson libdazzle-dev glib-dev gtk+3.0-dev gtksourceview4-dev
libxml2-dev libgit2-glib-dev template-glib-dev llvm-dev gspell-dev
enchant2-dev devhelp-dev sysprof-dev glade3-dev pcre-dev gtkmm3-dev
vte3-dev vala gobject-introspection-dev ctags clang-dev flatpak-dev
- libexecinfo-dev"
+ libexecinfo-dev glade-dev"
checkdepends="appstream-glib desktop-file-utils xvfb-run"
subpackages="$pkgname-dev $pkgname-lang"
source="https://download.gnome.org/sources/gnome-builder/${pkgver%.*}/gnome-builder-${pkgver}.tar.xz
- musl-wordsize.patch
- fix-appdata.patch"
+ fix-musl.patch"
build() {
export LIBS="$LIBS -lexecinfo"
@@ -41,6 +40,5 @@ package() {
DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="468605dbd2bd712a76c333a974bb19ca889dfe8493c2e85101641034f3e2c8eba2c0ee2f98ad01f3466f0f42946f05790763ccfaf786d73da192d64360eec47f gnome-builder-3.30.3.tar.xz
-5e422cdcf4cf6da968630afaf5b1a9a363d87ad577eb01c81fa2c1bfadbfe81ba1b20a516402edab5d505f5ba75ed53da6452b677c971f0e4b16b56c60238a95 musl-wordsize.patch
-885daaecad993f313652c40fec120876678c401967bdc0cc8ed947ef4334b21ed62f9e77a2898c8ddaf2d5d18ee8e69a76cdb87edb8e361c2b677efc8760700c fix-appdata.patch"
+sha512sums="f72e120c310da81be56954ba368332c65e6af581e7a1eedd9ee70df05ba17c7c1552deafed364646859b491fae77fb612f1a1fee18bff922fdcb49386465130e gnome-builder-3.32.3.tar.xz
+7e235b7591c73f4e19edcc9cfc17be65fa81d66ea4b098673c5750e6ab93cf8ba59a7d55d4d2f5bd44134608ad08664d905fd8e74d4941f09e6dc0257fa60547 fix-musl.patch"
diff --git a/testing/gnome-builder/fix-appdata.patch b/testing/gnome-builder/fix-appdata.patch
deleted file mode 100644
index a394cd9a317..00000000000
--- a/testing/gnome-builder/fix-appdata.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Why, oh why would you point these to master, upstream...
---- a/data/org.gnome.Builder.appdata.xml.in
-+++ b/data/org.gnome.Builder.appdata.xml.in
-@@ -39,27 +39,27 @@
- <screenshots>
- <screenshot type="default">
- <caption>Quickly access your projects</caption>
-- <image width="1600" height="900">https://gitlab.gnome.org/GNOME/gnome-builder/raw/master/data/appdata/01-greeter.png</image>
-+ <image width="2400" height="1350">https://gitlab.gnome.org/GNOME/gnome-builder/raw/master/data/appdata/01-greeter.png</image>
- </screenshot>
- <screenshot type="default">
- <caption>Create new projects from a variety of templates</caption>
-- <image width="1600" height="900">https://gitlab.gnome.org/GNOME/gnome-builder/raw/master/data/appdata/02-template.png</image>
-+ <image width="2400" height="1350">https://gitlab.gnome.org/GNOME/gnome-builder/raw/master/data/appdata/02-template.png</image>
- </screenshot>
- <screenshot type="default">
- <caption>Integration with Git to clone your projects</caption>
-- <image width="1600" height="900">https://gitlab.gnome.org/GNOME/gnome-builder/raw/master/data/appdata/03-clone.png</image>
-+ <image width="2400" height="1350">https://gitlab.gnome.org/GNOME/gnome-builder/raw/master/data/appdata/03-clone.png</image>
- </screenshot>
- <screenshot type="default">
- <caption>The source code editor</caption>
-- <image width="1600" height="900">https://gitlab.gnome.org/GNOME/gnome-builder/raw/master/data/appdata/04-editor.png</image>
-+ <image width="2400" height="1350">https://gitlab.gnome.org/GNOME/gnome-builder/raw/master/data/appdata/04-editor.png</image>
- </screenshot>
- <screenshot type="default">
- <caption>Fast global fuzzy search</caption>
-- <image width="1600" height="900">https://gitlab.gnome.org/GNOME/gnome-builder/raw/master/data/appdata/05-search.png</image>
-+ <image width="2400" height="1350">https://gitlab.gnome.org/GNOME/gnome-builder/raw/master/data/appdata/05-search.png</image>
- </screenshot>
- <screenshot type="default">
- <caption>Debug with the GNU debugger</caption>
-- <image width="1600" height="900">https://git.gnome.org/browse/gnome-builder/plain/data/appdata/06-debugger.png</image>
-+ <image width="2400" height="1350">https://gitlab.gnome.org/GNOME/gnome-builder/raw/master/data/appdata/06-debugger.png</image>
- </screenshot>
- </screenshots>
-
-
diff --git a/testing/gnome-builder/fix-musl.patch b/testing/gnome-builder/fix-musl.patch
new file mode 100644
index 00000000000..1aa572d26ef
--- /dev/null
+++ b/testing/gnome-builder/fix-musl.patch
@@ -0,0 +1,13 @@
+--- a/src/libide/foundry/ide-simple-build-system-discovery.c
++++ b/src/libide/foundry/ide-simple-build-system-discovery.c
+@@ -27,6 +27,10 @@
+ #endif
+ #include <fnmatch.h>
+
++#if !defined(FNM_EXTMATCH)
++#define FNM_EXTMATCH 0
++#endif
++
+ #include "ide-simple-build-system-discovery.h"
+
+ typedef struct
diff --git a/testing/gnome-builder/musl-wordsize.patch b/testing/gnome-builder/musl-wordsize.patch
deleted file mode 100644
index 22353fdc315..00000000000
--- a/testing/gnome-builder/musl-wordsize.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- a/src/plugins/sysprof/gbp-sysprof-plugin.c 2018-03-14 03:10:22.000000000 +0100
-+++ a/src/plugins/sysprof/gbp-sysprof-plugin.c 2018-04-10 15:20:46.416250960 +0200
-@@ -16,6 +16,11 @@
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-+#include <stdlib.h>
-+#if !defined(__GLIBC__)
-+#include <bits/reg.h> /* for __WORDSIZE */
-+#endif
-+
- #include <libpeas/peas.h>
- #include <ide.h>
- #include <sysprof.h>
---- a/src/plugins/sysprof/gbp-sysprof-perspective.c 2018-03-14 03:10:22.000000000 +0100
-+++ a/src/plugins/sysprof/gbp-sysprof-perspective.c 2018-04-10 15:12:49.793279369 +0200
-@@ -17,6 +17,10 @@
- */
-
- #define G_LOG_DOMAIN "gbp-sysprof-perspective"
-+#include <stdlib.h>
-+#if !defined(__GLIBC__)
-+#include <bits/reg.h> /* for __WORDSIZE */
-+#endif
-
- #include <glib/gi18n.h>
- #include <sysprof.h>
---- a/src/plugins/sysprof/gbp-sysprof-workbench-addin.c 2018-03-14 03:10:22.000000000 +0100
-+++ a/src/plugins/sysprof/gbp-sysprof-workbench-addin.c 2018-04-10 15:19:28.473255605 +0200
-@@ -16,6 +16,11 @@
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-+#include <stdlib.h>
-+#if !defined(__GLIBC__)
-+#include <bits/reg.h> /* for __WORDSIZE */
-+#endif
-+
- #include <glib/gi18n.h>
- #include <sysprof.h>
-