summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2019-12-17 14:15:09 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-18 19:54:20 +0000
commit79c609001f5e74909e0b044edc7834ca0b5670be (patch)
tree289bb73e2be94a462dd3f6f7f8759974e791253e
parent34d6671c3b0954c116253244b405fc9581788a95 (diff)
community/uboot-tools: Move example config file to examples
An example config file should not be in /etc. Lets move it where it belongs, into the examples. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
-rw-r--r--community/uboot-tools/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/community/uboot-tools/APKBUILD b/community/uboot-tools/APKBUILD
index 8675bee3cc3..63ed0be0981 100644
--- a/community/uboot-tools/APKBUILD
+++ b/community/uboot-tools/APKBUILD
@@ -2,12 +2,13 @@
# Maintainer: Fathi Boudra <fathi.boudra@linaro.org>
pkgname=uboot-tools
pkgver=2019.10
-pkgrel=0
+pkgrel=1
pkgdesc="U-Boot bootloader utility tools"
url="https://www.denx.de/wiki/U-Boot/WebHome"
arch="all !s390x !ppc64le"
license="GPL"
makedepends="$depends_dev bison flex openssl-dev linux-headers sdl-dev"
+subpackages="$pkgname-examples"
options="!check" # No test suite
source="http://ftp.denx.de/pub/u-boot/u-boot-$pkgver.tar.bz2
fix-ulong-typedef.patch
@@ -20,6 +21,12 @@ build() {
make tools-all
}
+examples() {
+ mkdir -p "${subpkgdir}/usr/share/doc/${pkgname}"
+ mv "${pkgdir}/usr/share/doc/${pkgname}/examples/" \
+ "${subpkgdir}/usr/share/doc/${pkgname}"
+}
+
package() {
cd "$builddir"
for tool in bmp_logo dumpimage env/fw_printenv \
@@ -29,7 +36,7 @@ package() {
$pkgdir/usr/bin/$(basename $tool)
done
install -Dm644 tools/env/fw_env.config \
- $pkgdir/etc/fw_env.config
+ "${pkgdir}/usr/share/doc/${pkgname}/examples/fw_env.config"
cd "$pkgdir"/usr/bin
ln -sf fw_printenv fw_setenv
}