summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-05-23 20:10:16 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2020-05-28 15:06:54 +0000
commit11e9491c7c804e82dc45dff606db647a51cc4e0b (patch)
tree1e963c421d153ef672cf940ac5ef8279ac231a63
parent8f7cf916fc0895b6d8061ded0ba65673f06764f4 (diff)
testing/shfmt: enable tests
-rw-r--r--testing/shfmt/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/shfmt/APKBUILD b/testing/shfmt/APKBUILD
index a7e7eb8543e..9da23994640 100644
--- a/testing/shfmt/APKBUILD
+++ b/testing/shfmt/APKBUILD
@@ -7,7 +7,6 @@ pkgdesc="A shell parser, formatter, and interpreter (sh/bash/mksh)"
url="https://mvdan.cc/sh"
arch="all"
license="BSD-3-Clause"
-options="!check" # no test suite
makedepends="go"
source="$pkgname-$pkgver.tar.gz::https://github.com/mvdan/sh/archive/v$pkgver.tar.gz"
builddir="$srcdir/sh-$pkgver"
@@ -19,6 +18,10 @@ build() {
./cmd/shfmt
}
+check() {
+ go test ./...
+}
+
package() {
install -Dm755 shfmt "$pkgdir"/usr/bin/shfmt
}