summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDermot Bradley <dermot_bradley@yahoo.com>2021-01-08 01:05:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2021-01-08 16:43:57 +0000
commitf84e119d465da70065c2207f6dd2315bd07c4f89 (patch)
tree5a26a87697823033823338573e170e7c7988afc6
parentda0e91f15ec8b8babbd76ae3205bfdac9765a188 (diff)
testing/jitterentropy-library: new aport
https://github.com/smuellerDD/jitterentropy-library Library for CPU Jitter Random Number Generator.
-rwxr-xr-xtesting/jitterentropy-library/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/jitterentropy-library/APKBUILD b/testing/jitterentropy-library/APKBUILD
new file mode 100755
index 00000000000..1a60d25cdb1
--- /dev/null
+++ b/testing/jitterentropy-library/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Dermot Bradley <dermot_bradley@yahoo.com>
+# Maintainer: Dermot Bradley <dermot_bradley@yahoo.com>
+pkgname=jitterentropy-library
+pkgver=3.0.0
+pkgrel=0
+pkgdesc="Jitterentropy library"
+url="http://www.chronox.de/jent.html"
+arch="all"
+license="BSD-3-Clause OR GPL-2.0-Only"
+subpackages="$pkgname-dev $pkgname-doc"
+options="!check" # There are no testcases
+source="jitterentropy-library-$pkgver.tar.gz::https://github.com/smuellerDD/jitterentropy-library/archive/v$pkgver.tar.gz
+ "
+
+build() {
+ make PREFIX=/usr
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="adb8769e84f8acd4e589fc83793405b0bb7820b4f9e029b5467e990fd85bd576516b7a14505d08b8b9bb303b4aa336649c58bc448325bbc1bded01c160772d99 jitterentropy-library-3.0.0.tar.gz"