summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-07 00:13:14 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-07 00:13:14 +0100
commit104da5ebb5da1487cbcb565509b90636b7fe0702 (patch)
treec267b1138457a1b4d9bf4e873f775edebb646bf2
parent4adef1df7794cc9919f7b297ca12c88f300d7932 (diff)
testing/httpie: improve abuild
-rw-r--r--testing/httpie/APKBUILD21
1 files changed, 4 insertions, 17 deletions
diff --git a/testing/httpie/APKBUILD b/testing/httpie/APKBUILD
index f44b8aa5220..960d1880fd3 100644
--- a/testing/httpie/APKBUILD
+++ b/testing/httpie/APKBUILD
@@ -7,31 +7,18 @@ pkgdesc="A CLI, cURL-like tool"
url="https://github.com/jkbr/httpie"
arch="noarch"
license="BSD"
-depends="python2 py-requests py-pygments"
-depends_dev=""
+depends="python2 py2-requests py-pygments"
makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py build || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}