summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-10-21 21:01:17 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:17 -0600
commit5a97de2d082062dce59bc6c35c2b99a764cee8f5 (patch)
tree4756373696194eb22fd441b170bc1da58de18be9
parent4fa21c023a470e024a8022a30c7136de235ef1c0 (diff)
Initial APKBUILD for py-paramiko
Package desscription: paramiko is a module for python 2.2 (or higher) that implements the SSH2 protocol for secure (encrypted and authenticated) connections to remote machines. unlike SSL (aka TLS), SSH2 protocol does not require heirarchical certificates signed by a powerful central authority. you may know SSH2 as the protocol that replaced telnet and rsh for secure access to remote shells, but the protocol also includes the ability to open arbitrary channels to remote services across the encrypted tunnel -- this is how sftp works, for example. http://www.lag.net/paramiko/
-rw-r--r--testing/py-paramiko/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py-paramiko/APKBUILD b/testing/py-paramiko/APKBUILD
new file mode 100644
index 00000000000..8e3717c6eaf
--- /dev/null
+++ b/testing/py-paramiko/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-paramiko
+_pkgname=paramiko
+pkgver=1.7.7.1
+pkgrel=0
+pkgdesc="SSH2 protocol library for Python"
+url="http://www.lag.net/paramiko/"
+arch="noarch"
+license="LGPL2+"
+depends=""
+depends_dev=""
+makedepends="py-crypto python-dev"
+install=""
+subpackages=""
+source="http://www.lag.net/paramiko/download/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="ce8e2c254378312a264206f65c354d72 paramiko-1.7.7.1.tar.gz"