summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Boerger <thomas@webhippie.de>2016-07-07 14:03:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-07-07 14:19:04 +0000
commitb1e1a9a87595458018b6e0e611679e30c142652f (patch)
treec1a7c44a2eeeccc27b36fe67275893f7c3c2e9d0
parenta8831019fb653fbb5f9d5a26497fb69bed5036a6 (diff)
testing/hugo: new aport
http://gohugo.io/ A Fast and Flexible Static Site Generator built with love in GoLang
-rw-r--r--testing/hugo/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/hugo/APKBUILD b/testing/hugo/APKBUILD
new file mode 100644
index 00000000000..dc1a4583cb2
--- /dev/null
+++ b/testing/hugo/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: Thomas Boerger <thomas@webhippie.de>
+pkgname=hugo
+pkgver=0.16
+pkgrel=0
+pkgdesc="A Fast and Flexible Static Site Generator built with love in GoLang"
+url="http://gohugo.io/"
+arch="all"
+license="Apache 2.0"
+depends=""
+depends_dev=""
+makedepends="$depends_dev go"
+install=""
+subpackages=""
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/spf13/hugo/archive/v$pkgver.tar.gz"
+
+builddir="${srcdir}/${pkgname}-${pkgver}"
+_godir="${srcdir}/go"
+_gourl="github.com/spf13/hugo"
+
+build() {
+ mkdir -p ${_godir}/bin ${_godir}/src/github.com/spf13
+ ln -sf ${builddir} ${_godir}/src/github.com/spf13/hugo
+
+ cd ${_godir}/src/${_gourl}
+ export GOPATH="${_godir}"
+
+ go get -d -v ./...
+ go install -v ${_gourl} || return 1
+}
+
+package() {
+ cd "$_godir"/bin
+
+ install -Dm755 hugo \
+ "${pkgdir}/usr/bin/hugo" || return 1
+}
+
+md5sums="9f5b952c08436cdff4baec9e73dfd6c5 hugo-0.16.tar.gz"
+sha256sums="a2dbb243535ba69ae8709ffe5ba340951a8834d2c0e86bb76c88d99ad77ef9f5 hugo-0.16.tar.gz"
+sha512sums="4c380d69d0616e43c991a67d499e31ff062b2f3714d944ce87252d1356445a08f59ac5eddebe572071318f1234f0b54cbb625632ba28b583cacffea5d728a230 hugo-0.16.tar.gz"