summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Boerger <thomas@webhippie.de>2016-07-06 10:05:25 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-07-06 18:37:10 +0200
commiteb153d4781a2adc93835e559bbb9742cad8ba36d (patch)
tree8201ff41a710dbb7c07abd32b5cf0c6646cbcf2a
parente47906aa357ff8aec33f68412def5b6ed37919fb (diff)
testing/py-pgspecial: new aport
https://pypi.python.org/pypi/pgspecial Meta-commands handler for Postgres Database
-rw-r--r--testing/py-pgspecial/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py-pgspecial/APKBUILD b/testing/py-pgspecial/APKBUILD
new file mode 100644
index 00000000000..2b83d95c8c1
--- /dev/null
+++ b/testing/py-pgspecial/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: Thomas Boerger <thomas@webhippie.de>
+pkgname=py-pgspecial
+_pkgname=pgspecial
+pkgver=1.5.0
+pkgrel=0
+pkgdesc="Meta-commands handler for Postgres Database"
+url="https://pypi.python.org/pypi/pgspecial"
+arch="noarch"
+license="BSD"
+depends="python py-click py-sqlparse"
+makedepends="python-dev py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="64e31255df5aa4d30026764667e0b7a1 py-pgspecial-1.5.0.tar.gz"
+sha256sums="cd4c4a0655be80f15eadc116a576f16c7147338e27f3f2fe8cc3fa6519a77891 py-pgspecial-1.5.0.tar.gz"
+sha512sums="1131449395ec36bb796ca4add0147621009ff6f59b458509a0f0158fdeb3a34e6358b35427be6f98b2fc54e1742c6e2ffad1026b2e1aa951370ad1732be30927 py-pgspecial-1.5.0.tar.gz"