summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-14 14:37:56 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-16 15:54:16 +0200
commit6d195678fd9858348fbda106bf947d2776e1b57d (patch)
tree82ab21180b2b788fb37ddbbec4577460ddf70249
parent6042a17af2bb813e64d8017c674c1fe41971deda (diff)
community/bluefish: upgrade to 2.2.10 and modernize
(cherry picked from commit 26d5dcca6f80796af2d340fb88bd601be3302460)
-rw-r--r--community/bluefish/APKBUILD29
1 files changed, 7 insertions, 22 deletions
diff --git a/community/bluefish/APKBUILD b/community/bluefish/APKBUILD
index ee0c6d7a2fd..5278c8b97ba 100644
--- a/community/bluefish/APKBUILD
+++ b/community/bluefish/APKBUILD
@@ -1,43 +1,28 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=bluefish
-pkgver=2.2.9
+pkgver=2.2.10
pkgrel=0
pkgdesc="Bluefish is an editor targeted towards programmers and webdevelopers"
url="http://bluefish.openoffice.nl/"
arch="all"
license="GPL"
-depends=""
-depends_dev=""
makedepends="libtool libxml2-dev python2-dev gtk+3.0-dev enchant-dev \
gucharmap-dev"
-install=""
subpackages="$pkgname-lang $pkgname-doc"
-source="http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.bz2"
-
-_builddir=${srcdir}/${pkgname}-${pkgver}
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="http://www.bennewitz.com/$pkgname/stable/source/$pkgname-$pkgver.tar.bz2"
+builddir=${srcdir}/${pkgname}-${pkgver}
build() {
- cd "$_builddir"
- ./configure --prefix=/usr || return 1
+ cd "$builddir"
+ ./configure --prefix=/usr
make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
}
-md5sums="57ff0ad3ea8470848e20c7a94f03073b bluefish-2.2.9.tar.bz2"
-sha256sums="5b717b563325bc6c2b6cb2700323c93eb08f914f204b322241d21744a079f7d0 bluefish-2.2.9.tar.bz2"
-sha512sums="ef644b37907d308b908d508ad00069e48343cd240ca7703a20b4498eda73be1a97a6c07598f6e51d4fb1c0f2a380c86a274ccbbe046da01db6c4641e41e268ae bluefish-2.2.9.tar.bz2"
+sha512sums="ddfad4c595d371dfd7ca5551c1771c2d82dbffcc90acda31bbd2a048730e24e2d1e37fbe847e5005d96acefdf5f38cb93785d23817e59624ecd7ea10bfbc3aeb bluefish-2.2.10.tar.bz2"