summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-01-27 03:27:18 +0200
committerAndy Postnikov <apostnikov@gmail.com>2019-01-27 03:31:54 +0200
commit3e9b99a6553d86ed30eeae43f717b2b47d14e99e (patch)
treefda346eed18a956a6e548cf79c47b1c17b81d42d
parent256c6b1d968b640a1aac5763fd6ad24287cfd0a7 (diff)
testing/py-apipkg: fix tests
https://github.com/pytest-dev/apipkg/issues/14
-rw-r--r--testing/py-apipkg/14.patch11
-rw-r--r--testing/py-apipkg/APKBUILD7
2 files changed, 15 insertions, 3 deletions
diff --git a/testing/py-apipkg/14.patch b/testing/py-apipkg/14.patch
new file mode 100644
index 00000000000..d2854e2e1a9
--- /dev/null
+++ b/testing/py-apipkg/14.patch
@@ -0,0 +1,11 @@
+--- a/test_apipkg.py
++++ b/test_apipkg.py
+@@ -13,7 +13,7 @@
+ class TestRealModule:
+
+ def setup_class(cls):
+- cls.tmpdir = py.test.ensuretemp('test_apipkg')
++ cls.tmpdir = py.path.local('test_apipkg')
+ sys.path = [str(cls.tmpdir)] + sys.path
+ pkgdir = cls.tmpdir.ensure('realtest', dir=1)
+
diff --git a/testing/py-apipkg/APKBUILD b/testing/py-apipkg/APKBUILD
index a3b27430157..2cefe1d0345 100644
--- a/testing/py-apipkg/APKBUILD
+++ b/testing/py-apipkg/APKBUILD
@@ -8,11 +8,11 @@ pkgdesc="apipkg: namespace control and lazy-import mechanism"
url="https://github.com/pytest-dev/apipkg"
arch="noarch"
license="MIT"
-options="check"
checkdepends="pytest"
makedepends="python2-dev python3-dev py-setuptools py-setuptools_scm"
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ 14.patch"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
@@ -50,4 +50,5 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="828937ca5e203915248fac54db8e7c13f941e006403f2a415c27fa4d1aa114790be3d7b5dd892f528611e5e6dfe75114ee80f4f4589a03c3f789ae6ddfcae0bf apipkg-1.5.tar.gz"
+sha512sums="828937ca5e203915248fac54db8e7c13f941e006403f2a415c27fa4d1aa114790be3d7b5dd892f528611e5e6dfe75114ee80f4f4589a03c3f789ae6ddfcae0bf apipkg-1.5.tar.gz
+96181be5cbc1bac03aa74347247fd4e97a8d2b3a93ebc8d412acdb3a02ae3792193234d18b0be626be2e76108c5803bd39ae995a98ecf324b8bc0e98a72bb7a8 14.patch"