aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrigory Kirillov <txgk@bk.ru>2022-10-30 15:50:28 +0300
committeralice <alice@ayaya.dev>2022-10-30 16:28:01 +0000
commit00254e4cac666b9d7c871775553ffe8ff259982d (patch)
tree765b5eb7bb0005ce3cf116a9cc2a73d6c0525cdf
parentb7550a28250b5c3f42816c0ac4d2cb8b7509cb19 (diff)
testing/libgivaro: rename from givaro
-rw-r--r--testing/libgivaro/APKBUILD (renamed from testing/givaro/APKBUILD)8
1 files changed, 4 insertions, 4 deletions
diff --git a/testing/givaro/APKBUILD b/testing/libgivaro/APKBUILD
index b41b80c8690..e9c6b72d7e8 100644
--- a/testing/givaro/APKBUILD
+++ b/testing/libgivaro/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Grigory Kirillov <txgk@bk.ru>
# Maintainer: Grigory Kirillov <txgk@bk.ru>
-pkgname=givaro
+pkgname=libgivaro
pkgver=4.2.0
pkgrel=0
pkgdesc="C++ library for arithmetic and algebraic computations"
@@ -10,6 +10,7 @@ license="CECILL-B"
makedepends="gmp-dev"
source="https://github.com/linbox-team/givaro/releases/download/v$pkgver/givaro-$pkgver.tar.gz"
subpackages="$pkgname-static $pkgname-dev"
+builddir="$srcdir/givaro-$pkgver"
build() {
export CFLAGS="${CFLAGS/-Os/-O3}" # gotta go fast
@@ -19,7 +20,7 @@ build() {
--build="$CBUILD" \
--host="$CHOST" \
--prefix=/usr \
- --enable-shared
+ --program-prefix=
make
}
@@ -29,8 +30,7 @@ check() {
package() {
make DESTDIR="$pkgdir" install
- mv "$pkgdir"/usr/bin/*givaro-config* "$pkgdir"/usr/bin/givaro-config
- rm "$pkgdir"/usr/share/givaro/givaro-makefile
+ rm -r "${pkgdir:?}"/usr/share
}
sha512sums="