aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-05-22 04:26:48 +0000
committerpsykose <alice@ayaya.dev>2023-05-22 06:26:49 +0200
commit007b9656f00d2171d8d002d7825e3da7d0c14135 (patch)
treee1494a56eefcf3716a35c1282726432153cebd84
parent1a000c24473ee4e7ec60513253423503c5bb5a0e (diff)
main/gtk+3.0: upgrade to 3.24.38
-rw-r--r--main/gtk+3.0/APKBUILD11
-rw-r--r--main/gtk+3.0/gl-context.patch28
2 files changed, 4 insertions, 35 deletions
diff --git a/main/gtk+3.0/APKBUILD b/main/gtk+3.0/APKBUILD
index 7b7574616a1..9bb7f02f8ca 100644
--- a/main/gtk+3.0/APKBUILD
+++ b/main/gtk+3.0/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gtk+3.0
-pkgver=3.24.37
-pkgrel=2
+pkgver=3.24.38
+pkgrel=0
pkgdesc="The GTK+ Toolkit (v3)"
url="https://www.gtk.org/"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
@@ -62,9 +62,7 @@ checkdepends="
ibus
xvfb-run
"
-source="https://download.gnome.org/sources/gtk+/${pkgver%.*}/gtk+-$pkgver.tar.xz
- gl-context.patch
- "
+source="https://download.gnome.org/sources/gtk+/${pkgver%.*}/gtk+-$pkgver.tar.xz"
builddir="$srcdir/gtk+-$pkgver"
build() {
@@ -133,6 +131,5 @@ icon_cache() {
}
sha512sums="
-118521686cb40c5b6ddfcc361be8ff8a16aced2108a24d1f6b7f29d32c235a77774d365b0bd283c9a6873003fca144d67793d12094c74d224a08fc1be341a22f gtk+-3.24.37.tar.xz
-e8f5ea8845e28f16e766382908a69fd1a1c57bc8379d602643d1792789514ec4477db14b801be731d496df914215abaac83f44beceb727af4e30f4a40359acb0 gl-context.patch
+e99ec10959191b55013fce37e83f0e85bf36597db101e324081479792a2047d032cf0d213d69c02eeb4b7cd6d56d6489b7b2a60904b2bd7af23ea1b9c5a79528 gtk+-3.24.38.tar.xz
"
diff --git a/main/gtk+3.0/gl-context.patch b/main/gtk+3.0/gl-context.patch
deleted file mode 100644
index e1513e7ac39..00000000000
--- a/main/gtk+3.0/gl-context.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Patch-Source: https://gitlab.gnome.org/GNOME/gtk/-/commit/66a94161bd35f1e008abe05cfe1e42ea119394a3
-https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/5754
---
-From 60d197fca8f59a78e7d8cffc505af34680bcf697 Mon Sep 17 00:00:00 2001
-From: Phil Stopford <philstopford@gmail.com>
-Date: Thu, 30 Mar 2023 22:34:55 +0000
-Subject: [PATCH] Address issue 5711 by checking that the context is not NULL.
-
----
- gdk/gdkgl.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/gdk/gdkgl.c b/gdk/gdkgl.c
-index 61cf16417b4..666b5e81335 100644
---- a/gdk/gdkgl.c
-+++ b/gdk/gdkgl.c
-@@ -367,7 +367,7 @@ gdk_cairo_draw_from_gl (cairo_t *cr,
-
- clip_region = gdk_cairo_region_from_clip (cr);
-
-- if (gdk_gl_context_get_current () != paint_context)
-+ if ((gdk_gl_context_get_current () != NULL) && (gdk_gl_context_get_current () != paint_context))
- sync = glFenceSync (GL_SYNC_GPU_COMMANDS_COMPLETE, 0);
-
- gdk_gl_context_make_current (paint_context);
---
-GitLab
-