aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuncan Bellamy <dunk@denkimushi.com>2020-06-14 09:09:14 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-06-14 12:19:13 +0000
commit0205027f95aed1f3d90a8956d931ba293c688f86 (patch)
tree7cd86fa59100b1a03a8b8bbb24c45bb37011af62
parent2bacd2aca0d10de600c2f58303bfbf524454b0d4 (diff)
community/rspamd: add patch to compile with new version of luajit
-rw-r--r--community/rspamd/11-moonjit.patch17
-rw-r--r--community/rspamd/APKBUILD4
2 files changed, 20 insertions, 1 deletions
diff --git a/community/rspamd/11-moonjit.patch b/community/rspamd/11-moonjit.patch
new file mode 100644
index 00000000000..c57a88a15c1
--- /dev/null
+++ b/community/rspamd/11-moonjit.patch
@@ -0,0 +1,17 @@
+add define to skip function providied by moonjit
+--- a/src/lua/lua_common.h
++++ b/src/lua/lua_common.h
+@@ -41,11 +41,13 @@
+ #endif
+
+ #if defined(LUA_VERSION_NUM) && LUA_VERSION_NUM == 501
++#if defined(LUAJIT_VERSION_NUM) && LUAJIT_VERSION_NUM < 20200
+ static inline int lua_absindex (lua_State *L, int i) {
+ if (i < 0 && i > LUA_REGISTRYINDEX)
+ i += lua_gettop(L) + 1;
+ return i;
+ }
++#endif
+ static inline int lua_rawgetp (lua_State *L, int i, const void *p) {
+ int abs_i = lua_absindex(L, i);
+ lua_pushlightuserdata(L, (void*)p);
diff --git a/community/rspamd/APKBUILD b/community/rspamd/APKBUILD
index eed18f89c61..9c220d2bbef 100644
--- a/community/rspamd/APKBUILD
+++ b/community/rspamd/APKBUILD
@@ -6,7 +6,7 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
pkgname=rspamd
pkgver=2.5
-pkgrel=6
+pkgrel=7
pkgdesc="Fast, free and open-source spam filtering system"
url="https://rspamd.com/"
arch="all"
@@ -49,6 +49,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/rspamd/rspamd/archive/$pkgve
$pkgname.confd
30-conf-split-workers.patch
20-default-configs.patch
+ 11-moonjit.patch
10-control_socket.patch
"
@@ -162,4 +163,5 @@ sha512sums="6068309da98eeb75f95188414b12ce9443aef31200853f820646e70e1dbf2d9d1e2c
a2003ef0c9d64a44480f59302864a2dfedcbe3a0047fcbb655408bc8aae9014b6ad0ddc6b64d4abeeb21bea0f86678afd30589ac8eed83e07ad7f87710e93702 rspamd.confd
a8aefee649bf6630339d1d3f2bb20c25ca70b21a8eaa92951e926d0fd4525f1d4ac4cc7ea66ac2b15323cf02c93c759ddf7181502f0d71b21384ced9d88c008e 30-conf-split-workers.patch
8801e3af59886847c25c87ca2f231cd9ededf35f376f9920967e72696fb017b1a4312f3a49017b52f65556bfe5c9f74a80405643afa32bb2906c38d39c5e1818 20-default-configs.patch
+a27aae810966f12590d3f86116813640bef91687bca9cb2b7a1febc7342e3ff7b40dbf5fc6e110a216ca087e477b7259ebf2ae327b57ae8eab8fac0a49cdf70a 11-moonjit.patch
6f828601ce460f2fd3b1c430974b719e36b0aa5600bd7074683fd646d99a4e76da35840b54c50416a9ae6d87babe39c5d463fc2ec05814e164a96d16f5da18b7 10-control_socket.patch"