aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2018-02-06 17:51:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-02-13 15:37:54 +0000
commit021396c8ddf8bf7b5cd6bd3e37b80e267a39b565 (patch)
tree45965182be6f8493a228ba4630d684b9f635bdd0
parent2cc301c6b460a1fcae12a05afdc8b943116dceff (diff)
community/py-msgpack: upgrade to 0.5.2
-rw-r--r--community/py-msgpack/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/community/py-msgpack/APKBUILD b/community/py-msgpack/APKBUILD
index 54a8a31431e..6be770415b2 100644
--- a/community/py-msgpack/APKBUILD
+++ b/community/py-msgpack/APKBUILD
@@ -2,24 +2,32 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-msgpack
_pkgname=msgpack-python
-pkgver=0.4.8
-pkgrel=2
+pkgver=0.5.2
+pkgrel=0
pkgdesc="A Python module for MessagePack serialization/deserialization"
-url="https://pypi.python.org/pypi/msgpack-python/"
+url="https://msgpack.org/"
arch="all"
license="Apache-2.0"
+# Dependency (pluggy) to run test is not available
+options="!check"
depends=""
-makedepends="python2-dev python3-dev py-setuptools"
+makedepends="python2-dev python3-dev py-setuptools pytest py3-pytest"
subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
+check() {
+ cd "$builddir"
+ pytest test
+ pytest-3 test
+}
+
package() {
mkdir -p "$pkgdir"
}
@@ -42,6 +50,4 @@ _py3() {
_py python3
}
-md5sums="dcd854fb41ee7584ebbf35e049e6be98 msgpack-python-0.4.8.tar.gz"
-sha256sums="1a2b19df0f03519ec7f19f826afb935b202d8979b0856c6fb3dc28955799f886 msgpack-python-0.4.8.tar.gz"
-sha512sums="59e9c43be6b92e6d10f40999e0902c350137e67a83c43bb15b273eca856a6eb39f24b625b02b40188a9365ce3101f03bfa9aa3dfff56c5c3b551533942183481 msgpack-python-0.4.8.tar.gz"
+sha512sums="a77666e440466f03154245161b279dd286d33a9fd8c81976fb401422f87e49c12bcb03063d1028b868c1562b9db69da50ffcb5d847dc4f872fe8d262f4f26d52 msgpack-python-0.5.2.tar.gz"