aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-02-08 05:17:10 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-02-08 20:10:48 +0000
commit02e61ce6c5d52a7c65390de46e0b9db8f4bac7e7 (patch)
tree7b10ab752e508368db8ce92e5acc9c982673fdeb
parent5f8c18f8490fb06bf92b4104cd549c66a1c6213f (diff)
community/pulseaudio: fix location of dbus configuration
-rw-r--r--community/pulseaudio/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/community/pulseaudio/APKBUILD b/community/pulseaudio/APKBUILD
index a3b435f341a..7c11bca163a 100644
--- a/community/pulseaudio/APKBUILD
+++ b/community/pulseaudio/APKBUILD
@@ -6,7 +6,7 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=pulseaudio
pkgver=14.2
-pkgrel=0
+pkgrel=1
pkgdesc="featureful, general-purpose sound server"
url="https://www.freedesktop.org/wiki/Software/PulseAudio/"
arch="all"
@@ -76,6 +76,13 @@ case "$CARCH" in
;;
esac
+prepare() {
+ default_prepare
+
+ sed -e "s|sysconfdir, 'dbus-1'|datadir, 'dbus-1'|" \
+ -i src/daemon/meson.build
+}
+
build() {
# -Dgstreamer=disabled because the GStreamer RTP protocol implementation is
# cosnidered experimental by upstream.