aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-14 12:55:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-17 03:50:04 +0000
commit0360f690e218e96ffba05e4a795f2b97e764ffe1 (patch)
treedb8e2e0756935690299731d3ae4448d3d4ca105a
parenta7083a96c7956c9196de76227fa70e9cd38067e1 (diff)
community/telegram-desktop: upgrade to 1.9.20
-rw-r--r--community/telegram-desktop/APKBUILD12
-rw-r--r--community/telegram-desktop/gcc9.patch37
2 files changed, 44 insertions, 5 deletions
diff --git a/community/telegram-desktop/APKBUILD b/community/telegram-desktop/APKBUILD
index c27bf48b2fd..f92e1381f98 100644
--- a/community/telegram-desktop/APKBUILD
+++ b/community/telegram-desktop/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
# Contributor: Leo <thinkabit.ukim@gmail.com>
pkgname=telegram-desktop
-pkgver=1.9.19
+pkgver=1.9.20
pkgrel=0
pkgdesc="Telegram Desktop messaging app"
options="!check" # Requires Catch2 to be packaged.
@@ -44,6 +44,7 @@ source="
https://github.com/telegramdesktop/tdesktop/releases/download/v$pkgver/tdesktop-$pkgver-full.tar.gz
qt-plugin-path.patch
small-sizes.patch
+ gcc9.patch
"
builddir="$srcdir/tdesktop-$pkgver-full"
@@ -68,7 +69,7 @@ build() {
-DTDESKTOP_FORCE_GTK_FILE_DIALOG=ON \
-DDESKTOP_APP_USE_PACKAGED_GSL=OFF \
-DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF \
- ${CMAKE_CROSSOPTS} .
+ $CMAKE_CROSSOPTS .
ninja -C build
}
@@ -81,7 +82,7 @@ package() {
strip -s build/bin/telegram-desktop
install -m755 build/bin/telegram-desktop -t "$pkgdir"/usr/bin
install -m644 lib/xdg/telegramdesktop.desktop -t "$pkgdir"/usr/share/applications
- install -m644 lib/xdg/telegramdesktop.appdata.xml -t "$pkgdir"/usr/share/appdata
+ install -m644 build/Telegram/telegramdesktop.appdata.xml -t "$pkgdir"/usr/share/appdata
for icon_size in 16 32 48 64 128 256 512; do
icon_dir="$pkgdir/usr/share/icons/hicolor/${icon_size}x$icon_size/apps"
@@ -92,6 +93,7 @@ package() {
done
}
-sha512sums="29070c6e1d813943d5062dc1703f383a18323b5698fbc4e6f2c89b33366da9da5d1ec84dc29950288e7e7d112024de2924244ec9c800d59d4b210e6288c7291d tdesktop-1.9.19-full.tar.gz
+sha512sums="d4f3b57a5b34f47b9a35517d15f7296509e9b2a160d6c8b77aae1c791e13c5171409c32be371bd8191bb8fbde3e32d03c380a99b5587a98c38b93f34c8cd7b52 tdesktop-1.9.20-full.tar.gz
183767e9a291dd605797cdc46382d8cb6a73a342348a40df7d52864ea27b3aa8709808cd51c46f5e611c247229ed336cb569bed1185c4c97b03171b56bbe5653 qt-plugin-path.patch
-3d1b8e6f870fc780f9ae8bc6a67eb676a5c5f686dc79e84cd6d64cb3cfafb1be626d0cc3960ffc67cecca21568764a0137c7303a89045fa59f91ba4eb5d8caed small-sizes.patch"
+3d1b8e6f870fc780f9ae8bc6a67eb676a5c5f686dc79e84cd6d64cb3cfafb1be626d0cc3960ffc67cecca21568764a0137c7303a89045fa59f91ba4eb5d8caed small-sizes.patch
+f80ad2cb4432d43f78265228f6b23d8705d455928346bbbdb65961ed6867fce712c8bd52b7c09d37f80fcf41abdcf793bd37e21e1c044b1ac3ffa59a7241b33d gcc9.patch"
diff --git a/community/telegram-desktop/gcc9.patch b/community/telegram-desktop/gcc9.patch
new file mode 100644
index 00000000000..49f9fd6a89c
--- /dev/null
+++ b/community/telegram-desktop/gcc9.patch
@@ -0,0 +1,37 @@
+From cf89b5a94411afa9d3f36e9f27e40426f8899bc1 Mon Sep 17 00:00:00 2001
+From: Ilya Fedin <fedin-ilja2010@ya.ru>
+Date: Sat, 14 Mar 2020 23:35:51 +0400
+Subject: [PATCH] Fix build with gcc 9
+
+---
+ .../SourceFiles/platform/linux/notifications_manager_linux.cpp | 2 +-
+ Telegram/SourceFiles/platform/linux/specific_linux.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Telegram/SourceFiles/platform/linux/notifications_manager_linux.cpp b/Telegram/SourceFiles/platform/linux/notifications_manager_linux.cpp
+index 6b9057437d..86382ab812 100644
+--- a/Telegram/SourceFiles/platform/linux/notifications_manager_linux.cpp
++++ b/Telegram/SourceFiles/platform/linux/notifications_manager_linux.cpp
+@@ -104,7 +104,7 @@ bool Inhibited() {
+ const QDBusReply<QVariant> reply = QDBusConnection::sessionBus().call(
+ message);
+
+- constexpr auto notSupportedErrors = {
++ const auto notSupportedErrors = {
+ QDBusError::ServiceUnknown,
+ QDBusError::InvalidArgs,
+ };
+diff --git a/Telegram/SourceFiles/platform/linux/specific_linux.cpp b/Telegram/SourceFiles/platform/linux/specific_linux.cpp
+index b9c5d3f0b8..916a26360f 100644
+--- a/Telegram/SourceFiles/platform/linux/specific_linux.cpp
++++ b/Telegram/SourceFiles/platform/linux/specific_linux.cpp
+@@ -374,7 +374,7 @@ std::optional<crl::time> LastUserInputTime() {
+ const QDBusReply<uint> reply = QDBusConnection::sessionBus().call(
+ message);
+
+- constexpr auto notSupportedErrors = {
++ const auto notSupportedErrors = {
+ QDBusError::ServiceUnknown,
+ QDBusError::NotSupported,
+ };
+