aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-22 15:55:46 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-22 16:03:58 +0000
commit03cbf84585c2e2c7c5747ee707063f32c0110e41 (patch)
tree898072f6df94927364daf710731103f4ffb49c69
parentf75f7c62b824b549d3e1c17e386bc4608f9904e8 (diff)
community/opencl-headers: fix source checksuming
-rw-r--r--community/opencl-headers/APKBUILD16
-rw-r--r--community/opencl-headers/LICENSE.txt35
2 files changed, 44 insertions, 7 deletions
diff --git a/community/opencl-headers/APKBUILD b/community/opencl-headers/APKBUILD
index b23a78b1e9c..589c8a58cc4 100644
--- a/community/opencl-headers/APKBUILD
+++ b/community/opencl-headers/APKBUILD
@@ -14,29 +14,31 @@ makedepends="$depends_dev"
install=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/itoffshore/OpenCL-Headers/archive/$pkgver.tar.gz
- $pkgname-$pkgver-LICENSE::https://github.com/KhronosGroup/OpenCL-ICD-Loader/raw/master/LICENSE.txt
+ LICENSE.txt
"
builddir="$srcdir"/$_pkgreal-$pkgver
+
build() {
return 0
}
package() {
cd "$builddir"
- mkdir -p "$pkgdir"/usr/include/CL
- mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ mkdir -p "$pkgdir"/usr/include/CL \
+ "$pkgdir"/usr/share/doc/$pkgname
for h in $(ls -1 *.h); do
install -m 644 $h "$pkgdir"/usr/include/CL/
done
- install -D -m644 ../$pkgname-$pkgver-LICENSE "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+ install -D -m644 ../LICENSE.txt \
+ "$pkgdir"/usr/share/doc/$pkgname/LICENSE
}
md5sums="04a5b1a34d0ce47520f08625d97ccfea opencl-headers-2.1.tar.gz
-ca6d58ec304a1ce6df094b52ca60c5ce opencl-headers-2.1-LICENSE"
+ec724732ce73269486574c718ef0c79b LICENSE.txt"
sha256sums="5d80fe3d9324b635e09d8891297c3c67e30635727d8dee99b9f3cefa73bf762e opencl-headers-2.1.tar.gz
-7c265341628a5f79ead4d8e00268649e16f2cb905ee21d713a2a0189cbd200b8 opencl-headers-2.1-LICENSE"
+30566989c3069521c673559e4201348629e1e4e49e0e2dde523b27c6bd1738ea LICENSE.txt"
sha512sums="0c475a6d44877289792ef055ed83df82c846e3c56df8dd1d3903965d6f817d99a7eb29b752be435f75485584036cb90e79e3c2035e2ddc99e04f30c0ada97edd opencl-headers-2.1.tar.gz
-d4bf5d67de13d6c67c935e4ada64469fba442d278a0469785d3d4221c94dec6b342ae703a30bd8b1510938d98afd9fb1813f3a14706037fb0f811466076154fb opencl-headers-2.1-LICENSE"
+9f5623f6c20a3e1c5b98f61499b91bb6e8b1cf8bcf2b0a986e2fa4474a2f2a7a6e9d122d2a0262d7c7b19adf4d32fb8cf4e99700984ceb6fbaef03426bb3834b LICENSE.txt"
diff --git a/community/opencl-headers/LICENSE.txt b/community/opencl-headers/LICENSE.txt
new file mode 100644
index 00000000000..7afedf6cf99
--- /dev/null
+++ b/community/opencl-headers/LICENSE.txt
@@ -0,0 +1,35 @@
+Copyright (c) 2016 The Khronos Group Inc.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software source and associated documentation files (the "Materials"),
+to deal in the Materials without restriction, including without limitation
+the rights to use, copy, modify, compile, merge, publish, distribute,
+sublicense, and/or sell copies of the Materials, and to permit persons to
+whom the Materials are furnished to do so, subject the following terms and
+conditions:
+
+All modifications to the Materials used to create a binary that is
+distributed to third parties shall be provided to Khronos with an
+unrestricted license to use for the purposes of implementing bug fixes and
+enhancements to the Materials;
+
+If the binary is used as part of an OpenCL(TM) implementation, whether binary
+is distributed together with or separately to that implementation, then
+recipient must become an OpenCL Adopter and follow the published OpenCL
+conformance process for that implementation, details at:
+http://www.khronos.org/conformance/;
+
+The above copyright notice, the OpenCL trademark license, and this permission
+notice shall be included in all copies or substantial portions of the
+Materials.
+
+THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE MATERIALS OR THE USE OR OTHER DEALINGS IN
+THE MATERIALS.
+
+OpenCL is a trademark of Apple Inc. used under license by Khronos.
+