aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-12-21 20:26:47 +0100
committerTBK <tbk@jjtc.eu>2020-12-21 22:34:04 +0000
commit043d5fb3cf72595c58a2bd50feddfe1d780f1239 (patch)
tree675b86a5e1b00d0aed0c075a686092c2b6780082
parent79ca4039127caec4b117b094688e181fe5be2a3f (diff)
downloadaports-043d5fb3cf72595c58a2bd50feddfe1d780f1239.tar.gz
aports-043d5fb3cf72595c58a2bd50feddfe1d780f1239.tar.bz2
aports-043d5fb3cf72595c58a2bd50feddfe1d780f1239.tar.xz
testing/mycroft-core: remove unnecessary py3-six dependency
Also order all lists alphabetically
-rw-r--r--community/mycroft-core/APKBUILD48
1 files changed, 44 insertions, 4 deletions
diff --git a/community/mycroft-core/APKBUILD b/community/mycroft-core/APKBUILD
index f80149ec47..fa771bc2dd 100644
--- a/community/mycroft-core/APKBUILD
+++ b/community/mycroft-core/APKBUILD
@@ -2,18 +2,58 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=mycroft-core
pkgver=20.8.0
-pkgrel=3
+pkgrel=4
pkgdesc="Mycroft Core, the Mycroft Artificial Intelligence platform"
url="https://mycroft.ai/"
# mips, mips64 and s390x blocked by py3-precise-runner
# s390x blocked by mimic1
arch="noarch !mips !mips64 !s390x"
license="Apache-2.0"
-depends="python3 py3-six py3-requests py3-gtts py3-pyaudio py3-pyee py3-speechrecognition py3-tornado py3-websocket-client py3-requests-futures py3-serial py3-psutil py3-pocketsphinx py3-inflection py3-pillow py3-dateutil py3-fasteners py3-yaml py3-lingua-franca mycroft-skills-manager mycroft-skills-kit py3-adapt-parser py3-padatious py3-fann2 py3-padaos py3-precise-runner py3-petact py3-xdg mimic1"
+depends="
+ mimic1
+ mycroft-skills-kit
+ mycroft-skills-manager
+ py3-adapt-parser
+ py3-dateutil
+ py3-fann2
+ py3-fasteners
+ py3-gtts
+ py3-inflection
+ py3-lingua-franca
+ py3-padaos
+ py3-padatious
+ py3-petact
+ py3-pillow
+ py3-pocketsphinx
+ py3-precise-runner
+ py3-psutil
+ py3-pyaudio
+ py3-pyee
+ py3-requests
+ py3-requests-futures
+ py3-serial
+ py3-speechrecognition
+ py3-tornado
+ py3-websocket-client
+ py3-xdg
+ py3-yaml
+ python3
+ "
# These dependencies are required to play audio with the local backend
-depends="$depends cmd:paplay cmd:mpg123 cmd:ogg123"
+# mpg123: mpg123
+# pulseaudio-utils: paplay
+# vorbis-tools: ogg123
+depends="$depends
+ mpg123
+ pulseaudio-utils
+ vorbis-tools
+ "
# Minimum skills required for functionality
-depends="$depends mycroft-skill-fallback-unknown mycroft-skill-pairing mycroft-skill-configuration"
+depends="$depends
+ mycroft-skill-configuration
+ mycroft-skill-fallback-unknown
+ mycroft-skill-pairing
+ "
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-wheel py3-vlc"
install="$pkgname.post-install"