aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-06-16 15:38:36 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-06-16 15:31:48 +0200
commit065772daaf144c1207924e74d458c884dc7dac12 (patch)
treee387f7f919940e92da87f4015765a42939ff80eb
parente8badd7bac0819e3e73e6a2ed5d99eeca35ee98c (diff)
community/crystal: fix test failure due to timezone
-rw-r--r--community/crystal/APKBUILD6
-rw-r--r--community/crystal/fix-spec-time-location.patch14
2 files changed, 18 insertions, 2 deletions
diff --git a/community/crystal/APKBUILD b/community/crystal/APKBUILD
index 4264632e33a..c0b5fd70246 100644
--- a/community/crystal/APKBUILD
+++ b/community/crystal/APKBUILD
@@ -21,6 +21,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/crystal-lang/$pkgname/archiv
https://dev.alpinelinux.org/archive/crystal/crystal-$_bootver-aarch64-alpine-linux-musl.tar.gz
paxmark.patch
disable-specs-using-GB2312-encoding.patch
+ fix-spec-time-location.patch
libressl.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -121,6 +122,7 @@ zshcomp() {
sha512sums="20f2864919c7710e5aee8112e1c6ab54a2e50b244ac63d374edfed41ab659b11c062f76dbfc38e763a08bdbea9e0a39f3b5cac5e00bf453be3a31d3b0a023917 crystal-0.25.0.tar.gz
6d7ee01ff5bfaaf79fa80c15575ae4496e17629ed18cb0577db6734266c2dbf5b0bf0a554c7c153e1b81f4c71e62bb803fd4b6513e3d039571ee4f953d85ecf4 crystal-0.24.2-x86_64-alpine-linux-musl.tar.gz
d6ed122a5ddb4e1ea772357cd3115dcf8cd92a75f973b6f7e4b8b6135fb4123fb98334495f6f312da7ab7ba3bda57bd3cb4f06c0f421df2c09d19c0ab1b8b67b crystal-0.24.2-aarch64-alpine-linux-musl.tar.gz
-31fd94f07edb83eb6ff43dd20f99a52e3c28dc0bf67f7e0b5c473c40d455febfbd0cdf9fe1fe599dbf080fd4c05a2a2d9ad8745f9effc8dfb565e19fa0e49509 libressl.patch
dec4ed7abfd215eec825bed97b1e40bf3aa8bd959a4ec7153ea1bc51d409d892ebec19ddb0372e3a543e74c7018aca0c1f3cf956fa1d95efb946c8c3417c8749 paxmark.patch
-269976fbc990dde075769e651c9fac6e7e0b39681e55cbd067c6d2a790c58a096bdc9981f62ae69b5217623025ba768daa63bc5316bd8ddd18192d88839aedcb disable-specs-using-GB2312-encoding.patch"
+269976fbc990dde075769e651c9fac6e7e0b39681e55cbd067c6d2a790c58a096bdc9981f62ae69b5217623025ba768daa63bc5316bd8ddd18192d88839aedcb disable-specs-using-GB2312-encoding.patch
+518f06dd191e43e4052c0f8c4963d31dfc7ed3b414d1bb2e7a82265af13853f85380b5507ef3c5a5a25f6091d7173d5322f379e354666eec4165264dd502e70b fix-spec-time-location.patch
+31fd94f07edb83eb6ff43dd20f99a52e3c28dc0bf67f7e0b5c473c40d455febfbd0cdf9fe1fe599dbf080fd4c05a2a2d9ad8745f9effc8dfb565e19fa0e49509 libressl.patch"
diff --git a/community/crystal/fix-spec-time-location.patch b/community/crystal/fix-spec-time-location.patch
new file mode 100644
index 00000000000..3bb086f7986
--- /dev/null
+++ b/community/crystal/fix-spec-time-location.patch
@@ -0,0 +1,14 @@
+This test fail on builders; probably the timezone is set to UTC there.
+
+--- a/spec/std/time/location_spec.cr
++++ b/spec/std/time/location_spec.cr
+@@ -162,9 +162,6 @@
+ end
+
+ it ".load_local" do
+- with_env("TZ", nil) do
+- Location.load_local.name.should eq "Local"
+- end
+ with_zoneinfo do
+ with_env("TZ", "Europe/Berlin") do
+ Location.load_local.name.should eq "Europe/Berlin"