aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-07-02 14:29:17 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-07-03 10:03:11 +0000
commit06cd83abb7b68b2ff25a3cbcf85021fe0b2e26d6 (patch)
treec46bd8ded1b85e91c3b367dd7374e1b84913c81d
parent9e606e1c9c5ae0a1716e470f40dd7faf5101b233 (diff)
community/waylandpp: upgrade to 0.2.8
-rw-r--r--community/waylandpp/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/community/waylandpp/APKBUILD b/community/waylandpp/APKBUILD
index ffa1b255e76..0103d44e090 100644
--- a/community/waylandpp/APKBUILD
+++ b/community/waylandpp/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=waylandpp
-pkgver=0.2.7
-pkgrel=1
+pkgver=0.2.8
+pkgrel=0
arch="all"
url="https://github.com/NilsBrause/waylandpp"
options="!check" # No tests are run
@@ -10,23 +10,24 @@ pkgdesc="Wayland C++ bindings"
license="MIT AND GPL-3.0-or-later"
depends_dev="pugixml-dev wayland-dev mesa-dev"
makedepends="$depends_dev cmake doxygen graphviz"
-source="$pkgname-$pkgver.tar.gz::https://github.com/nilsbrause/waylandpp/archive/$pkgver.tar.gz"
+source="https://github.com/nilsbrause/waylandpp/archive/$pkgver/waylandpp-$pkgver.tar.gz"
subpackages="$pkgname-dev $pkgname-doc"
build() {
- cmake \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make
+ cmake --build build
}
check() {
+ cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="67ec76d9bc0146472d70364c98b6b5af957c757a95d55c224ef2d9bf8b3ab15dc4f6333dca1ad803d94403be11abe7055db54d9fc708c6f5c0196f6a328a5ed2 waylandpp-0.2.7.tar.gz"
+sha512sums="bf1b8a9e69b87547fc65989b9eaff88a442d8b2f01f5446cef960000b093390b1e557536837fbf38bb6d9a4f93e3985ea34c3253f94925b0f571b4606c980832 waylandpp-0.2.8.tar.gz"