aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-21 20:33:28 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-08-22 12:56:35 +0000
commit078c371335d8be4a054b0ce7185dae90dede9b35 (patch)
tree5127636cd71261cbf547ebed68882799ede22446
parentcb800ebc10039026780eef7c3a3ebf8f933b8924 (diff)
main/mt-st: upgrade to 1.3
-rw-r--r--main/mt-st/APKBUILD41
-rw-r--r--main/mt-st/musl-path_max.patch18
2 files changed, 14 insertions, 45 deletions
diff --git a/main/mt-st/APKBUILD b/main/mt-st/APKBUILD
index a2e96301e83..175b1e956b0 100644
--- a/main/mt-st/APKBUILD
+++ b/main/mt-st/APKBUILD
@@ -1,45 +1,32 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=mt-st
-pkgver=1.1
-pkgrel=5
+pkgver=1.3
+pkgrel=0
pkgdesc="Linux SCSI tape driver aware magnetic tape control"
url="http://www.ibiblio.org/pub/linux/system/backup/"
arch="all"
-license="GPL-2.0"
-depends=
-makedepends='linux-headers'
-install=
+license="GPL-2.0-or-later"
+makedepends="linux-headers"
subpackages="$pkgname-doc"
-source="http://www.ibiblio.org/pub/linux/system/backup/$pkgname-$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/iustin/mt-st/archive/mt-st-$pkgver.tar.gz
mt-st-include-sysmacros.patch
- musl-path_max.patch"
+ "
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgname-$pkgver
build() {
- cd "$_builddir"
- make || return 1
+ cd "$builddir"
+ make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
for dir in sbin bin usr/share/man/man1 usr/share/man/man8
do
- mkdir -p $pkgdir/$dir || return 1
+ mkdir -p $pkgdir/$dir
done
- make SBINDIR=$pkgdir/sbin BINDIR=$pkgdir/bin \
- MANDIR=$pkgdir/usr/share/man install || return 1
+ make SBINDIR=$pkgdir/sbin BINDIR=$pkgdir/bin MANDIR=$pkgdir/usr/share/man install
}
-sha512sums="5fd11c430219c9c2d98f7567433a59c689e6f1bf9a2aaa13eb8df58569c1d70417965a4a62b5c9d0fc7e4e520ecb8d745911d18c3e2652c6aaedb94850743fdb mt-st-1.1.tar.gz
-621711dc38436285f98f587a43393c505a101c1a99d3c2b652660cef98c6532813620d6f34fa7ca55fe2e13383e6b5c4930dad5996b4007262a6fdea449c18a7 mt-st-include-sysmacros.patch
-207f355497930cb466f5e3ad9601098381da1555709f9dafdbc85efcd5ea9cb8299e22c54b34b12d8fb9880dec75c3f625b3065438f7284bbcdef21b4de82555 musl-path_max.patch"
+sha512sums="d2eab36778b4c56c2bc12fc92dd9aae6a4488934b34f0244e7c461a1f0c5c14663f338bc1337502d3b5feac113b2dbc1f969cd4c1acf6df0bbc6b9a3409882de mt-st-1.3.tar.gz
+621711dc38436285f98f587a43393c505a101c1a99d3c2b652660cef98c6532813620d6f34fa7ca55fe2e13383e6b5c4930dad5996b4007262a6fdea449c18a7 mt-st-include-sysmacros.patch"
diff --git a/main/mt-st/musl-path_max.patch b/main/mt-st/musl-path_max.patch
deleted file mode 100644
index 935abbc16dc..00000000000
--- a/main/mt-st/musl-path_max.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./stinit.c.orig
-+++ ./stinit.c
-@@ -8,6 +8,7 @@
- Last modified: Sun Apr 27 14:24:16 2008 by kai.makisara
- */
-
-+#define _GNU_SOURCE
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-@@ -16,6 +17,7 @@
- #include <errno.h>
- #include <fcntl.h>
- #include <dirent.h>
-+#include <limits.h>
- #include <sys/stat.h>
- #include <sys/ioctl.h>
- #include <sys/sysmacros.h>