aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-26 01:46:30 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-26 01:46:30 -0300
commit078df917ca9a73fbc84d9eb6b9e4c14682a28a1a (patch)
tree833f4e17557067b8f6abcb80f2503611ececcaf9
parent3a89b155d268332f9b7f874aa41b832de6f850ad (diff)
downloadaports-078df917ca9a73fbc84d9eb6b9e4c14682a28a1a.tar.gz
aports-078df917ca9a73fbc84d9eb6b9e4c14682a28a1a.tar.bz2
aports-078df917ca9a73fbc84d9eb6b9e4c14682a28a1a.tar.xz
{main,community,testing}: make terminals depend on ncurses-terminfo-base
-rw-r--r--community/xterm/APKBUILD4
-rw-r--r--main/putty/APKBUILD4
-rw-r--r--main/tmux/APKBUILD10
3 files changed, 7 insertions, 11 deletions
diff --git a/community/xterm/APKBUILD b/community/xterm/APKBUILD
index af6c73c4975..6f1f4803639 100644
--- a/community/xterm/APKBUILD
+++ b/community/xterm/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=xterm
pkgver=346
-pkgrel=1
+pkgrel=2
pkgdesc="X Terminal Emulator"
options="!check" # Requires vttest
url="http://invisible-island.net/xterm"
arch="all"
license="MIT"
-depends="ncurses-terminfo"
+depends="ncurses-terminfo-base"
makedepends="libxaw-dev libxft-dev ncurses-dev"
subpackages="$pkgname-doc"
source="ftp://ftp.invisible-island.net/xterm/$pkgname-$pkgver.tgz
diff --git a/main/putty/APKBUILD b/main/putty/APKBUILD
index dd8ab2bc0f7..01e9151d29b 100644
--- a/main/putty/APKBUILD
+++ b/main/putty/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Jeff Bilyk <jbilyk@alpinelinux.org>
pkgname=putty
pkgver=0.73
-pkgrel=1
+pkgrel=2
pkgdesc="SSH and telnet client"
url="https://www.chiark.greenend.org.uk/~sgtatham/putty/"
arch="all"
license="MIT"
-depends="ncurses-terminfo"
+depends="ncurses-terminfo-base"
makedepends="linux-headers"
subpackages="$pkgname-doc"
source="http://the.earth.li/~sgtatham/putty/$pkgver/putty-$pkgver.tar.gz
diff --git a/main/tmux/APKBUILD b/main/tmux/APKBUILD
index 0086f668f45..33d9df04cac 100644
--- a/main/tmux/APKBUILD
+++ b/main/tmux/APKBUILD
@@ -2,20 +2,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tmux
pkgver=2.9a
-pkgrel=0
+pkgrel=1
pkgdesc="Tool to control multiple terminals from a single terminal"
url="https://tmux.github.io"
arch="all"
license="ISC"
-depends="ncurses-terminfo"
+depends="ncurses-terminfo-base"
makedepends="autoconf automake bsd-compat-headers libevent-dev ncurses-dev"
subpackages="$pkgname-doc"
-source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/tmux/tmux/releases/download/$pkgver/tmux-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,12 +25,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -D -m644 example_tmux.conf \