aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-03 10:26:31 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-17 10:23:25 +0000
commit07d605eef2a3873190300ee05c406f329da31b59 (patch)
tree115e2a29a91ac5364f8f072b0bc98ce5cb96e472
parentea05d8c376a161a4813663e1952477468765759a (diff)
community/pdsh: fix build without git installed
Insert package version with sed instead of relying on 'git describe'.
-rw-r--r--community/pdsh/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/pdsh/APKBUILD b/community/pdsh/APKBUILD
index 8f89dcdb4ba..eeb4f2f28af 100644
--- a/community/pdsh/APKBUILD
+++ b/community/pdsh/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=pdsh
pkgver=2.33
-pkgrel=0
+pkgrel=1
pkgdesc="A high performance, parallel remote shell utility"
url="https://github.com/chaos/pdsh"
arch="all"
@@ -20,6 +20,7 @@ prepare() {
default_prepare
cd "$builddir"
+ sed -i "s|m4_esyscmd(\[git describe .*\])|[$pkgver]|" configure.ac
./bootstrap
}