aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-12 00:02:49 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-15 18:08:54 -0300
commit08d9b1aa546b05a03279fb9fc2d2ea5facaebe66 (patch)
tree801892fbad31f1b3c7c749205956b26a0f15eadf
parent7b58edb897f944e0070a5fa7ea2071f305a5d53e (diff)
community/py-snmp: upgrade to 4.4.11
-rw-r--r--community/py-snmp/APKBUILD18
-rw-r--r--community/py-snmp/remove-bogus-check.patch25
2 files changed, 35 insertions, 8 deletions
diff --git a/community/py-snmp/APKBUILD b/community/py-snmp/APKBUILD
index d7e0966ff36..be171e07404 100644
--- a/community/py-snmp/APKBUILD
+++ b/community/py-snmp/APKBUILD
@@ -2,21 +2,22 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-snmp
_pkgname=pysnmp
-pkgver=4.4.5
-pkgrel=1
+pkgver=4.4.11
+pkgrel=0
pkgdesc="A Python SNMP v1/v2c/v3 engine"
-url="http://pysnmp.sf.net/"
+url="http://snmplabs.com/pysnmp/index.html"
arch="noarch"
-license="BSD"
+license="BSD-2-Clause"
options="!check"
depends="py-asn1 py-crypto"
-makedepends="python2-dev py-setuptools python3-dev"
+makedepends="py-setuptools py3-setuptools"
subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ remove-bogus-check.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python2 setup.py build
python3 setup.py build
}
@@ -46,4 +47,5 @@ _py3() {
_py python3
}
-sha512sums="3164e93a8623512d903c86eebdb6f9fa5ffee29309747df4a836e257e87dc5480cf706ab527e1a8966e80c0626961f6f1b68b60cf07df2ddece305706f5445f2 pysnmp-4.4.5.tar.gz"
+sha512sums="0f61ad0c095398b4b511c854ea7156aae78495f299457b14f4d3b50833670ec77c905e9cf4bdc30c21dd3c3e62d1c3473d7895f0352140af6345b18c1db3e7d8 pysnmp-4.4.11.tar.gz
+7976030882c78154a8db4250f1bcb634e74f7f7bd2ec5002dee89605b2cc1845fe92287ea22a2f0eb564fd8c2f3efdcac3370bafadb9eb54925646d6f57e677a remove-bogus-check.patch"
diff --git a/community/py-snmp/remove-bogus-check.patch b/community/py-snmp/remove-bogus-check.patch
new file mode 100644
index 00000000000..4ce19a0c2f4
--- /dev/null
+++ b/community/py-snmp/remove-bogus-check.patch
@@ -0,0 +1,25 @@
+diff --git a/setup.py b/setup.py
+index 0d987d5..82da3ad 100644
+--- a/setup.py
++++ b/setup.py
+@@ -63,19 +63,6 @@ try:
+
+ setup, Command = setuptools.setup, setuptools.Command
+
+- observed_version = [int(x) for x in setuptools.__version__.split('.')]
+- required_version = [36, 2, 0]
+-
+- # NOTE(etingof): require fresh setuptools to build proper wheels
+- # See also: https://hynek.me/articles/conditional-python-dependencies/
+- if ('bdist_wheel' in sys.argv and
+- observed_version < required_version):
+- print("ERROR: your wheels won't come out round with setuptools %s! "
+- "Upgrade to %s and try again." % (
+- '.'.join([str(x) for x in observed_version]),
+- '.'.join([str(x) for x in required_version])))
+- sys.exit(1)
+-
+ params = {
+ 'install_requires': requires,
+ 'zip_safe': True
+