aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2022-07-04 19:26:25 +0200
committerHenrik Riomar <henrik.riomar@gmail.com>2022-07-06 08:53:35 +0000
commit08ed1f9aa84d58fa53c40e94a399ce54cef44cd4 (patch)
treeac60634970bdb3c81d9ddfcfa51ea7c77759124a
parentbebeb000b30568ec2154a2d3d59a7e5bf537f70a (diff)
testing/getmail6: new aport
-rw-r--r--testing/getmail6/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/getmail6/APKBUILD b/testing/getmail6/APKBUILD
new file mode 100644
index 00000000000..c4cfde2ae8d
--- /dev/null
+++ b/testing/getmail6/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer: Henrik Riomar <henrik.riomar@gmail.com>
+pkgname=getmail6
+pkgver=6.18.9
+pkgrel=0
+pkgdesc="mail retriever with support for POP3, IMAP4 and SDPS"
+url="https://getmail6.org/"
+arch="noarch"
+license="GPL-2.0-only"
+checkdepends="py3-pytest"
+makedepends="py3-setuptools"
+subpackages="$pkgname-doc"
+source="https://github.com/getmail6/getmail6/archive/v$pkgver/getmail-$pkgver.tar.gz"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$PWD/build/lib" pytest -v test/test.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ mv "$pkgdir/usr/share/doc/getmail-$pkgver" "$pkgdir/usr/share/doc/$pkgname"
+}
+
+sha512sums="
+dfeaebbca0c8766a16783d27171e65595d97a4b557943677dd7e7a66a9da8b49dfdbfb4aba9655ce3815ff6e2f991905317085b156ba6dbac841bb0fbb26c8b5 getmail-6.18.9.tar.gz
+"