aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-01-17 21:18:30 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-01-17 21:18:30 -0300
commit096f04f0e1be9d51ee39fa9453f0acad0ef2f435 (patch)
tree11e8887d1f2aa98770108c1e56976d29744f9660
parent211932f6e55643cd5b8be06197876727615eea78 (diff)
downloadaports-096f04f0e1be9d51ee39fa9453f0acad0ef2f435.tar.gz
aports-096f04f0e1be9d51ee39fa9453f0acad0ef2f435.tar.bz2
aports-096f04f0e1be9d51ee39fa9453f0acad0ef2f435.tar.xz
testing/*: add lua5.4 support for more lua packages
-rw-r--r--testing/lua-linenoise/APKBUILD6
-rw-r--r--testing/lua-linotify/APKBUILD8
-rw-r--r--testing/lua-middleclass/APKBUILD4
-rw-r--r--testing/lua-schema/APKBUILD7
4 files changed, 10 insertions, 15 deletions
diff --git a/testing/lua-linenoise/APKBUILD b/testing/lua-linenoise/APKBUILD
index 53a7b4b878..65cc70627c 100644
--- a/testing/lua-linenoise/APKBUILD
+++ b/testing/lua-linenoise/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lua-linenoise
pkgver=0.9
-pkgrel=0
+pkgrel=1
pkgdesc="Lua bindings for linenoise"
url="https://github.com/hoelzro/lua-linenoise"
arch="all"
@@ -9,7 +9,7 @@ license="MIT"
makedepends="linenoise-dev"
source="lua-linenoise-$pkgver.tar.gz::https://github.com/hoelzro/lua-linenoise/archive/$pkgver.tar.gz"
-_luaversions="5.1 5.2 5.3"
+_luaversions="5.1 5.2 5.3 5.4"
for _v in $_luaversions; do
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
makedepends="$makedepends lua$_v-dev"
@@ -32,7 +32,7 @@ package() {
_subpackage() {
local lua="${subpkgname%-*}"
local lver=${lua#lua}
- pkgdesc="$pkgdesc (for Lua ${lver})"
+ pkgdesc="$pkgdesc (for Lua $lver)"
depends="$lua"
install_if="$pkgname=$pkgver-r$pkgrel $lua"
diff --git a/testing/lua-linotify/APKBUILD b/testing/lua-linotify/APKBUILD
index ddbba85fef..d2bcf337c4 100644
--- a/testing/lua-linotify/APKBUILD
+++ b/testing/lua-linotify/APKBUILD
@@ -2,21 +2,17 @@
# Maintainer:
pkgname=lua-linotify
pkgver=0.5
-pkgrel=0
+pkgrel=1
pkgdesc="Inotify bindings for Lua"
url="https://github.com/hoelzro/linotify"
arch="all"
license="MIT"
-depends=""
-makedepends=""
-install=""
-subpackages=""
source="linotify-$pkgver.tar.gz::https://github.com/hoelzro/linotify/archive/$pkgver.tar.gz
makefile.patch
"
builddir="$srcdir/linotify-$pkgver"
-_luaversions="5.1 5.2 5.3"
+_luaversions="5.1 5.2 5.3 5.4"
for _v in $_luaversions; do
makedepends="$makedepends lua$_v-dev"
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
diff --git a/testing/lua-middleclass/APKBUILD b/testing/lua-middleclass/APKBUILD
index 05ffe6f959..44046a29dc 100644
--- a/testing/lua-middleclass/APKBUILD
+++ b/testing/lua-middleclass/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer:
pkgname=lua-middleclass
pkgver=4.1.1
-pkgrel=0
-_luaversions="5.1 5.2 5.3"
+pkgrel=1
+_luaversions="5.1 5.2 5.3 5.4"
pkgdesc="Object-orientation for Lua"
url="https://github.com/kikito/middleclass"
arch="noarch"
diff --git a/testing/lua-schema/APKBUILD b/testing/lua-schema/APKBUILD
index 007e0aae66..207b9a96da 100644
--- a/testing/lua-schema/APKBUILD
+++ b/testing/lua-schema/APKBUILD
@@ -4,17 +4,16 @@ _rockname=$pkgname
_rockver=scm-1
_commit=e3e504df922da6175dbb055b091710ae46a44a14
pkgver=0_git20170304
-pkgrel=0
-pkgdesc="A simple package to check LUA-data against schemata"
+pkgrel=1
+pkgdesc="simple package to check LUA-data against schemata"
url="https://github.com/sschoener/lua-schema"
arch="noarch"
license="MIT"
-provides=
source="$url/archive/$_commit.zip"
builddir="$srcdir/$pkgname-$_commit"
options="!check"
-_luaversions="5.2 5.3"
+_luaversions="5.2 5.3 5.4"
for _v in $_luaversions; do
provides="$provides lua$_v-${pkgname#lua-}=$pkgver-r$pkgrel"
done