aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-07 15:57:34 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-09-30 20:24:03 +0000
commit0b7df2731e6e69629102d215c3a319dcbe9026c9 (patch)
tree78433b45fe5b69d150876ba44416dd3c6bd3c972
parent8447eba86d77ff876f493f686f729b6a94d6f461 (diff)
main/libxdg-basedir: fix url enable tests
Closes !178
-rw-r--r--main/libxdg-basedir/APKBUILD41
1 files changed, 17 insertions, 24 deletions
diff --git a/main/libxdg-basedir/APKBUILD b/main/libxdg-basedir/APKBUILD
index 3d5d8b82fd0..18ed00eac2e 100644
--- a/main/libxdg-basedir/APKBUILD
+++ b/main/libxdg-basedir/APKBUILD
@@ -1,45 +1,38 @@
-# Contributor:
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxdg-basedir
pkgver=1.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="library for XDG base dir specification"
-url="http://n.ethz.ch/~nevillm/download/libxdg-basedir/"
+url="https://git.universe-factory.net/libuecc"
arch="all"
license="MIT"
-depends=
-depends_dev=
-makedepends="$depends_dev"
-install=""
+makedepends="autoconf automake libtool"
subpackages="$pkgname-dev"
-source="https://dev.alpinelinux.org/archive/libxdg-basedir/libxdg-basedir-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/devnev/libxdg-basedir/archive/libxdg-basedir-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgname-$pkgver"
-_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
- local i
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ autoreconf -fi
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
- || return 1
- make || return 1
+ --disable-static
+ make
}
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+check() {
+ cd "$builddir"
+ make check
}
-sha512sums="346553ddd9d0a0c854af9320f2ced695a0838adc18736b66120bea48ea60cb9ea3a7390672a42f83909db92f692e94de833d9e8bcfe51568a72ad1f4661fde06 libxdg-basedir-1.2.0.tar.gz"
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="8584405d45e0b57e570666b6eab6d99d70411d00f88965826c9ed0292372385668f190157a10ff536f3a5a59fd0031b332ecbb8a38ac64eda1b04a0603997406 libxdg-basedir-1.2.0.tar.gz"