aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-03-01 17:39:29 -0700
committerHenrik Riomar <henrik.riomar@gmail.com>2019-03-02 10:02:00 +0100
commit0d4e93632f80dea321dcabd6055e77693d8c5f95 (patch)
tree16b0e48a1178b3ee8ede372a2a625b780a306da6
parent4af974dab41b51e4280937ffcaeef34cac345c39 (diff)
testing/slurp: new APKBUILD
-rw-r--r--testing/slurp/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/slurp/APKBUILD b/testing/slurp/APKBUILD
new file mode 100644
index 00000000000..02136a0f491
--- /dev/null
+++ b/testing/slurp/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=slurp
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Interaction screen selection on Wayland compositors"
+url="https://wayland.emersion.fr/slurp/"
+arch="all"
+license="MIT"
+makedepends="meson scdoc cairo-dev wayland-dev wayland-protocols"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/emersion/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ cd "$builddir"
+ ./output/slurp -h >/dev/null
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="ef0120133095d6bb2c5f6df297eaac19890da1d65ead0dd84ee6f15be295eb956dc8357d62e66fd4c2082d1cccfe936bf401fba847b27fc9193903b39236c84f slurp-1.1.0.tar.gz"