aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2021-08-01 01:59:20 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2021-08-01 01:59:20 +0200
commit0e39eadba41d43ce1597ad1eb243711b5aeb970a (patch)
tree31ec16a96b77c28b2e971f7121ee2dd40202d326
parent03dafa80dae9ec40ea499428176fdfa7f40db169 (diff)
downloadaports-0e39eadba41d43ce1597ad1eb243711b5aeb970a.tar.gz
aports-0e39eadba41d43ce1597ad1eb243711b5aeb970a.tar.bz2
aports-0e39eadba41d43ce1597ad1eb243711b5aeb970a.tar.xz
community/alacritty: fix use with bitmap fonts and freetype-2.11.4
This is a backport of an upstream change. See: * https://github.com/alacritty/alacritty/commit/259e7c7a09f343b28ad34254f3880e9c4cf5c5ec * https://github.com/alacritty/alacritty/issues/5353 Fixes #12858.
-rw-r--r--community/alacritty/APKBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/community/alacritty/APKBUILD b/community/alacritty/APKBUILD
index 31ab743c364..bd195abad91 100644
--- a/community/alacritty/APKBUILD
+++ b/community/alacritty/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=alacritty
-pkgver=0.8.0
-pkgrel=0
+pkgver=0.8.0 # XXX: Remove prepare() when upgrading to 0.9.0
+pkgrel=1
pkgdesc="A cross-platform, GPU-accelerated terminal emulator"
url="https://github.com/jwilm/alacritty"
arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # limited by rust/cargo
@@ -22,6 +22,15 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/jwilm/alacritty/archive/v$pk
export CARGO_HOME="$srcdir"/cargo
export RUSTFLAGS="-C target-feature=-crt-static"
+prepare() {
+ default_prepare
+
+ # Fix for https://gitlab.alpinelinux.org/alpine/aports/-/issues/12858
+ #
+ # This is a backport of an upstream change and can be removed with 0.9.0.
+ cargo update -p crossfont --precise 0.3.1
+}
+
build() {
cargo build --release --verbose
}