aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-01-09 00:20:18 +0000
committeralice <alice@ayaya.dev>2023-01-11 11:20:33 +0000
commit0f09691a6d10e534f73bbff16e4ff280f2dfacef (patch)
treed757c9716db0d2059258ca8afe320e7ac57bd6f0
parentf2ce4c5e1ee5d891d9ac9797628d092179d10227 (diff)
downloadaports-0f09691a6d10e534f73bbff16e4ff280f2dfacef.tar.gz
aports-0f09691a6d10e534f73bbff16e4ff280f2dfacef.tar.bz2
aports-0f09691a6d10e534f73bbff16e4ff280f2dfacef.tar.xz
testing/dwl: upgrade to 0.4
-rw-r--r--testing/dwl/APKBUILD13
-rw-r--r--testing/dwl/xwayland.patch12
2 files changed, 20 insertions, 5 deletions
diff --git a/testing/dwl/APKBUILD b/testing/dwl/APKBUILD
index 71869471b29..53c9c4836a6 100644
--- a/testing/dwl/APKBUILD
+++ b/testing/dwl/APKBUILD
@@ -1,15 +1,17 @@
# Maintainer: Dekedro <dekedro@tankers.xyz>
pkgname=dwl
-pkgver=0.3.1
-pkgrel=1
+pkgver=0.4
+pkgrel=0
pkgdesc="dwm for wayland"
url="https://github.com/djpohly/dwl"
arch="all"
license="GPL-3.0-or-later"
-makedepends="wlroots0.15-dev wayland-protocols"
+makedepends="wlroots-dev wayland-protocols"
options="!check" # no tests
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/djpohly/dwl/archive/refs/tags/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/djpohly/dwl/archive/refs/tags/v$pkgver.tar.gz
+ xwayland.patch
+ "
build() {
make
@@ -20,5 +22,6 @@ package() {
}
sha512sums="
-c6bcaf26d6f67f7712f907331c947afc84a5c5b990f5ec6d568d65f624a2cafd1617055ed514cd7e8a331abcd4c37ed574672dcbeeb890607d8eb38e7a304215 dwl-0.3.1.tar.gz
+6e15e05001e6469d13bef2d532980585d57de55c8feb461a7c25a76d7cdaee022785485faca02cd9d1214457fbeb1bec0eb652700ba0ddccca4aa780df0046b2 dwl-0.4.tar.gz
+7c7952ede929faa137f690b3d1f44c1af4b40a3a6dac7bc3d5a377c8c454b35de1becdbbd1f3cbbde56c798f4f3bf78bc7eef4d7faa0e761d317179c072c629f xwayland.patch
"
diff --git a/testing/dwl/xwayland.patch b/testing/dwl/xwayland.patch
new file mode 100644
index 00000000000..4bed22b3e17
--- /dev/null
+++ b/testing/dwl/xwayland.patch
@@ -0,0 +1,12 @@
+diff --git a/config.mk b/config.mk
+index f50156f..a20a8f0 100644
+--- a/config.mk
++++ b/config.mk
+@@ -10,5 +10,5 @@ MANDIR = $(PREFIX)/share/man
+ XWAYLAND =
+ XLIBS =
+ # Uncomment to build XWayland support
+-#XWAYLAND = -DXWAYLAND
+-#XLIBS = xcb xcb-icccm
++XWAYLAND = -DXWAYLAND
++XLIBS = xcb xcb-icccm