aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-08-05 16:35:58 +0000
committerpsykose <alice@ayaya.dev>2022-08-05 18:35:58 +0200
commit0f22c144c182c2217560ea5b1cd4eef93cefb150 (patch)
tree6e8597ec76533c6a4e23ea42fa0a9a5cb57746a3
parentb5246f05fc9b80c1df5d7294470914472663742e (diff)
main/icu: remove -full dependency on dev
similarly to the previous commit, starting on 3.16, adding postgresql-dev, then trying to upgrade to edge, yields: ERROR: unable to select packages: icu-data-en-71.1-r3: conflicts: icu-data-full-71.1-r3[icu-data=71.1-r3] satisfies: icu-libs-71.1-r3[icu-data=71.1-r3] icu-data-full-71.1-r3: conflicts: icu-data-en-71.1-r3[icu-data=71.1-r3] satisfies: icu-dev-71.1-r3[icu-data-full=71.1-r3] icu-libs-71.1-r3[icu-data=71.1-r3] adding the full data first seems to work fine, though: / # apk add icu-data-full (1/5) Installing icu-data-full (71.1-r3) (2/5) Upgrading icu-libs (71.1-r2 -> 71.1-r3) (3/5) Upgrading icu (71.1-r2 -> 71.1-r3) (4/5) Upgrading icu-dev (71.1-r2 -> 71.1-r3) (5/5) Purging icu-data-en (71.1-r2) Executing busybox-1.35.0-r15.trigger OK: 343 MiB in 36 packages / # apk upgrade -alU (1/32) Upgrading alpine-baselayout-data (3.2.0-r22 -> 3.3.0-r0) but having -full only be pulled in on upgrade from a previous -en between repositories seems to not work as intended- apk cannot resolve that -full will replace -en while also swapping repositories. (or maybe there is another reason..?) since this was added mostly for tests in aports (out of lazyness), just get rid of it and fix it elsewhere later.
-rw-r--r--main/icu/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/icu/APKBUILD b/main/icu/APKBUILD
index 6110fdd1469..eeae0c066c7 100644
--- a/main/icu/APKBUILD
+++ b/main/icu/APKBUILD
@@ -3,12 +3,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=icu
pkgver=71.1
-pkgrel=3
+pkgrel=4
pkgdesc="International Components for Unicode library"
url="https://icu.unicode.org/"
arch="all"
license="MIT ICU Unicode-TOU"
-depends_dev="$pkgname=$pkgver-r$pkgrel $pkgname-data-full=$pkgver-r$pkgrel"
+depends_dev="$pkgname=$pkgver-r$pkgrel"
makedepends="python3 py3-yaml"
checkdepends="diffutils"
install="$pkgname-data-en.post-install"