aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2019-11-21 09:23:28 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-21 09:27:48 +0100
commit101cd4e14edf3d9b92edeb70832be5e7e55707cc (patch)
tree7cc43a7a1ef0aac207a60a53acfdf98a4c76082e
parent50a3d6142c6d3fea36189011fba71e4932f201aa (diff)
testing/py3-pass-git-helper: new aport
https://github.com/languitar/pass-git-helper A git credential helper interfacing with pass, the standard unix password manager. testing/
-rw-r--r--testing/py3-pass-git-helper/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-pass-git-helper/APKBUILD b/testing/py3-pass-git-helper/APKBUILD
new file mode 100644
index 00000000000..a6b4c89e16b
--- /dev/null
+++ b/testing/py3-pass-git-helper/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname="py3-pass-git-helper"
+_pyname="pass-git-helper"
+pkgver="1.1.0"
+pkgrel=0
+pkgdesc="A git credential helper interfacing with pass, the standard unix password manager."
+url="https://github.com/languitar/pass-git-helper"
+arch="noarch"
+license="LGPL-3.0-only"
+depends="python3 pass py3-xdg"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-cov py3-pytest-mock"
+source="$_pyname-$pkgver.tar.gz::https://github.com/languitar/$_pyname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="d636f27d09619d077f64d62200353143499209c6c405848396d2e39f54f16fdf3e0fb9471d231fd8bd52eb8b30df42e2c448a9677028badf812de986b4cda86b pass-git-helper-1.1.0.tar.gz"