aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-05-08 10:11:53 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-05-15 02:00:29 +0000
commit109acf488d8a5b369d9fb7dda89466027377f6f5 (patch)
tree1b13cde700b704e754d2d35a25ef58800b134db8
parent0bf7c7db70258cf01aa11a5d3cf726b89c87da80 (diff)
main/itstool: upgrade to 2.0.6
Modernise and enable full test suite Changelog: https://github.com/itstool/itstool/blob/master/NEWS#L1
-rw-r--r--main/itstool/APKBUILD27
-rw-r--r--main/itstool/fix-segfault.patch2
2 files changed, 14 insertions, 15 deletions
diff --git a/main/itstool/APKBUILD b/main/itstool/APKBUILD
index abab2d4a1a0..7b1028ef999 100644
--- a/main/itstool/APKBUILD
+++ b/main/itstool/APKBUILD
@@ -1,20 +1,24 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=itstool
-pkgver=2.0.4
-pkgrel=3
+pkgver=2.0.6
+pkgrel=0
pkgdesc="ITS-based XML translation tool"
url="http://itstool.org/"
arch="noarch"
license="GPL-3.0-or-later"
depends="py3-libxml2 python3"
+makedepends="autoconf automake"
+checkdepends="diffutils gettext"
subpackages="$pkgname-doc"
-source="http://files.itstool.org/itstool/$pkgname-$pkgver.tar.bz2
+source="$pkgname-$pkgver.tar.gz::https://github.com/itstool/itstool/archive/$pkgver.tar.gz
fix-segfault.patch"
-builddir="$srcdir/$pkgname-$pkgver"
-build() {
- cd "$builddir"
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
+build() {
PYTHON="/usr/bin/python3" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,17 +31,12 @@ build() {
}
check() {
- cd "$builddir"
- make check
- # verify that the shebang is correct
- chmod +x itstool
- ./itstool
+ python3 tests/run_tests.py
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="f5cfa9c75710f9cc43a61caeb92ca04ec77023bce6fb14d770dda82efde2e5d9050245618c249d309227a3d43555cb1739f5fe680b4a370786ed4631fa9ee4b7 itstool-2.0.4.tar.bz2
-eb426e7cc9f151154f47b93ef46d6fcfb5fa0982be3bf78863ebf5ea009a89de252a6c63dfb090d76003c47107ebb5d1ac2a7d1ef7db08defe19e32f996dbdbd fix-segfault.patch"
+sha512sums="900889d7c668eb87b516334702c926f1195e105a3568bc66c6bbc2b7e94302f6ae394a7de293dc516d11bca04fb1a25d150da06901c74df1a3714bdeb0a9cd03 itstool-2.0.6.tar.gz
+a47ab86ee0ea7b8fa8329649cda28db91e106ffdc695836e55f274b406759e3945835dbaf32230a30f2afaf482aff0ef205a12d722a19a6ab874c8f33413df9a fix-segfault.patch"
diff --git a/main/itstool/fix-segfault.patch b/main/itstool/fix-segfault.patch
index 047b691b748..3de72e9faa9 100644
--- a/main/itstool/fix-segfault.patch
+++ b/main/itstool/fix-segfault.patch
@@ -14,7 +14,7 @@ diff --git a/itstool.in b/itstool.in
index c1d0585..e492e95 100755
--- a/itstool.in
+++ b/itstool.in
-@@ -1048,7 +1048,7 @@ class Document (object):
+@@ -1053,7 +1053,7 @@ class Document (object):
else:
ctxt.replaceEntities(1)
ctxt.parseDocument()