aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-07-20 15:45:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-09-17 11:34:44 +0000
commit10e40b3f87bd3f885c866269695429e040cbcb72 (patch)
treeefe81f4397a7b9e4e388f4a0d0546965bedf8a98
parent9d26e332941a1174c40c27df4c9debbae52296d7 (diff)
downloadaports-10e40b3f87bd3f885c866269695429e040cbcb72.tar.gz
aports-10e40b3f87bd3f885c866269695429e040cbcb72.tar.bz2
aports-10e40b3f87bd3f885c866269695429e040cbcb72.tar.xz
community/gnome-feeds: add runtime deps on py3-dateutil and py3-pillow
fixes #11760 (cherry picked from commit 0095009dd1dcc7a9d4e89d670cddedabd68217ff)
-rw-r--r--community/gnome-feeds/APKBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/community/gnome-feeds/APKBUILD b/community/gnome-feeds/APKBUILD
index 33a60c84f3f..8987df8c943 100644
--- a/community/gnome-feeds/APKBUILD
+++ b/community/gnome-feeds/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-feeds
pkgver=0.13.4
-pkgrel=1
+pkgrel=2
pkgdesc="An RSS/Atom feed reader for GNOME"
url="https://gitlab.gnome.org/World/gfeeds"
arch="noarch"
license="GPL-3.0-or-later"
depends="py3-html5lib webkit2gtk py3-lxml py3-requests py3-feedparser gtk+3.0
py3-beautifulsoup4 py3-listparser py3-tz py3-readability py3-pygments
- py3-gobject3"
+ py3-gobject3 py3-dateutil py3-pillow"
makedepends="meson gettext glib-dev gobject-introspection-dev gtk+3.0-dev"
subpackages="$pkgname-lang"
source="https://gitlab.gnome.org/World/gfeeds/-/archive/$pkgver/gfeeds-$pkgver.tar.gz
@@ -17,22 +17,16 @@ source="https://gitlab.gnome.org/World/gfeeds/-/archive/$pkgver/gfeeds-$pkgver.t
builddir="$srcdir/gfeeds-$pkgver"
build() {
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=plain \
- . output
- ninja -C output
+ abuild-meson . output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
}
check() {
- ninja -C output test
+ meson test --no-rebuild -v -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="df0328c403fcfb171bbda130afc4c2e58f18b7bbcbbea5ffa845719f29a48a6b6fed672e3580e2fc5c50e22977d85e1050323f596358c0cf0ca59ddfd569934e gfeeds-0.13.4.tar.gz