aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-01 15:42:37 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 15:18:54 +0000
commit13129b99661d439847296d2609e361ccda81e0b4 (patch)
tree86a391cb88f374f050d802b5fa8bad310bcdb513
parentcbe1c6c8a287ec0a7c4005f35604835414bbb7da (diff)
community/uhttpmock: add patch to only listen on IPv4
* fix url & license * enable tests * modernize APKBUILD Closes GH-7597
-rw-r--r--community/uhttpmock/APKBUILD34
-rw-r--r--community/uhttpmock/only-listen-on-ipv4.patch16
2 files changed, 33 insertions, 17 deletions
diff --git a/community/uhttpmock/APKBUILD b/community/uhttpmock/APKBUILD
index 3a34f74b19e..d198c24d560 100644
--- a/community/uhttpmock/APKBUILD
+++ b/community/uhttpmock/APKBUILD
@@ -1,21 +1,19 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uhttpmock
pkgver=0.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="HTTP web service mocking library"
-url="http://gitorious.org/uhttpmock/"
+url="https://gitlab.com/uhttpmock/uhttpmock"
arch="all"
-license="LGPL-2.0"
-depends=""
+license="LGPL-2.1-or-later"
makedepends="glib-dev libsoup-dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://tecnocode.co.uk/downloads/uhttpmock/$pkgname-$pkgver.tar.xz"
-
-builddir="$srcdir"/uhttpmock-$pkgver
+checkdepends="gsettings-desktop-schemas"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
+source="https://tecnocode.co.uk/downloads/uhttpmock/$pkgname-$pkgver.tar.xz
+ only-listen-on-ipv4.patch"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -23,15 +21,17 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var \
- --disable-static \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-sha512sums="99135c0983be78eaaf962e5b182eaaf921e1d6ed30f98691d8766e9d4a9e07188965ce3f546a13a8c32b148bad305083cc3cfdf48d9a8b91efffaec5a46d8006 uhttpmock-0.5.1.tar.xz"
+sha512sums="99135c0983be78eaaf962e5b182eaaf921e1d6ed30f98691d8766e9d4a9e07188965ce3f546a13a8c32b148bad305083cc3cfdf48d9a8b91efffaec5a46d8006 uhttpmock-0.5.1.tar.xz
+1125328a45694d669e9b9e8594c022d8d1a40e5c1a07adf53a9b4002288191bf0db13ca5c5f3e60d21b56a03ebf43f9fda10aaef1d09376e818a0a0eee4a108e only-listen-on-ipv4.patch"
diff --git a/community/uhttpmock/only-listen-on-ipv4.patch b/community/uhttpmock/only-listen-on-ipv4.patch
new file mode 100644
index 00000000000..64a43672fa1
--- /dev/null
+++ b/community/uhttpmock/only-listen-on-ipv4.patch
@@ -0,0 +1,16 @@
+Upstream: No
+Reason: Docker by default doesn't enable IPv6, so tests using this will fail on
+CI and infra.
+diff --git a/libuhttpmock/uhm-server.c b/libuhttpmock/uhm-server.c
+index 5f59a23..11b113d 100644
+--- a/libuhttpmock/uhm-server.c
++++ b/libuhttpmock/uhm-server.c
+@@ -1393,7 +1393,7 @@ uhm_server_run (UhmServer *self)
+ g_main_context_push_thread_default (priv->server_context);
+
+ priv->server_main_loop = g_main_loop_new (priv->server_context, FALSE);
+- soup_server_listen_local (priv->server, 0, SOUP_SERVER_LISTEN_HTTPS,
++ soup_server_listen_local (priv->server, 0, SOUP_SERVER_LISTEN_HTTPS | SOUP_SERVER_LISTEN_IPV4_ONLY,
+ &error);
+ g_assert_no_error (error); /* binding to localhost should never really fail */
+