aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-06-24 02:43:13 +0000
committeralice <alice@ayaya.dev>2022-06-25 18:54:45 +0000
commit136df876fc5e9c8a65b2d9dfef560a99e3245f69 (patch)
treefe54f42618dc77b2db8d34690a1c40597ac93297
parentcf18053a64ee1987f7a3bc9581dbb1a608d7dd96 (diff)
community/filecheck: upgrade to 0.0.22
and use poetry-core
-rw-r--r--community/filecheck/APKBUILD18
-rw-r--r--community/filecheck/poetry-core.patch11
2 files changed, 23 insertions, 6 deletions
diff --git a/community/filecheck/APKBUILD b/community/filecheck/APKBUILD
index d2e6f118de4..d3f7851150f 100644
--- a/community/filecheck/APKBUILD
+++ b/community/filecheck/APKBUILD
@@ -1,22 +1,27 @@
# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=filecheck
-pkgver=0.0.21
-pkgrel=1
+pkgver=0.0.22
+pkgrel=0
pkgdesc="Attempt to reimplement LLVM's FileCheck using Python"
url="https://github.com/mull-project/FileCheck.py"
arch="noarch"
license="Apache-2.0"
depends="python3"
-makedepends="py3-setuptools poetry py3-installer"
+makedepends="py3-poetry-core py3-build py3-installer"
checkdepends="py3-pytest"
-source="https://github.com/mull-project/FileCheck.py/archive/v$pkgver/filecheck-$pkgver.tar.gz"
+source="https://github.com/mull-project/FileCheck.py/archive/v$pkgver/filecheck-$pkgver.tar.gz
+ poetry-core.patch
+ "
builddir="$srcdir/FileCheck.py-$pkgver"
build() {
# poetry-core excludes files specified in .gitignore
# fixed by setting GIT_DIR to somewhere that isn't a git repository
- GIT_DIR="$builddir" poetry build -f wheel
+ GIT_DIR="$builddir" python3 -m build \
+ --no-isolation \
+ --wheel \
+ --skip-dependency-check
}
check() {
@@ -29,5 +34,6 @@ package() {
}
sha512sums="
-9b21fd1bbfc92d077280d4c68a5dbdabd3644fd47a840d640ba548e49c701184d5c6823e46550774d6c619b780e7bed7174e3be2d57579c7ffed80b119b76c00 filecheck-0.0.21.tar.gz
+f7d5385c396ef379376668ffd9359ad6203be2f56c807125e3c63e7664ccccff0045bc1c9fffe2c30e8cc91f028d6a386dbb19e4eaa5f3a35bb62bd98d278b90 filecheck-0.0.22.tar.gz
+a673878a604201d6a8b664b1baabb7f10612bf446a6d93823847c220d9603f68c0d635ec7645d7ca45ed5f4ea2c7a38dc87fa247d4e646d809b47a00a4ce04bb poetry-core.patch
"
diff --git a/community/filecheck/poetry-core.patch b/community/filecheck/poetry-core.patch
new file mode 100644
index 00000000000..d91a0ffb35a
--- /dev/null
+++ b/community/filecheck/poetry-core.patch
@@ -0,0 +1,11 @@
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -22,7 +22,7 @@
+
+ [build-system]
+ requires = ["poetry>=0.12"]
+-build-backend = "poetry.masonry.api"
++build-backend = "poetry.core.masonry.api"
+
+ [tool.black]
+ line-length = 80