aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuncan Bellamy <dunk@denkimushi.com>2020-08-16 09:26:59 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-08-16 21:19:41 +0000
commit137de502e4378b960166411b35bf05795b089fbb (patch)
tree94081ff98950ecbe236ca7a4d2a4422334409b31
parent3141508f70d8e609d14214d703e2232ee15da06b (diff)
main/hiredis: upgrade to 1.0.0
* add hiredis-ssl sub package fix lint errors try let to fix lint error
-rw-r--r--main/hiredis/APKBUILD20
-rw-r--r--main/hiredis/musl-test.patch11
2 files changed, 11 insertions, 20 deletions
diff --git a/main/hiredis/APKBUILD b/main/hiredis/APKBUILD
index 907a93221a3..a8ed25f2769 100644
--- a/main/hiredis/APKBUILD
+++ b/main/hiredis/APKBUILD
@@ -1,20 +1,20 @@
# Contributor: Eivind Uggedal <eu@eju.no>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hiredis
-pkgver=0.14.1
+pkgver=1.0.0
pkgrel=0
pkgdesc="Minimalistic C client library for Redis"
url="https://github.com/redis/hiredis"
arch="all"
license="BSD-3-Clause"
+makedepends="openssl-dev"
checkdepends="redis"
-subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
- musl-test.patch"
+subpackages="$pkgname-ssl $pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
build() {
- make PREFIX=/usr DEBUG="$CFLAGS" LDFLAGS="$LDFLAGS"
+ make USE_SSL=1 PREFIX=/usr DEBUG="$CFLAGS" LDFLAGS="$LDFLAGS"
}
check() {
@@ -25,7 +25,7 @@ check() {
local _n=100 # wait up to 10 sec
while ! [ -e "$builddir"/redis.sock ] && [ $_n -gt 0 ]; do
sleep 0.1s
- _n=$(( $_n - 1))
+ let _n="$_n - 1"
done
make hiredis-test
@@ -34,9 +34,11 @@ check() {
}
package() {
- make PREFIX="$pkgdir"/usr install
+ make USE_SSL=1 PREFIX="$pkgdir"/usr install
}
+ssl() {
+ amove usr/lib/libhiredis_ssl.so*
+}
-sha512sums="a7310f2d65075df0c17636a0220e16487759471a3442b1de2595ab747565f6b6262e37131613b13e396b31050bcbe5529c35d420cd43fd7d500d9d563d469c4f hiredis-0.14.1.tar.gz
-a16c212e6c391a0434ffbd865b241cebfc6f46acc282ac6a651fb2dea7e30991fe5a2ef267dded03eb13c6d4012d7588f9d1224596da4782bc93b5fd6829c117 musl-test.patch"
+sha512sums="eb56201121eecdbfc8d42e8c2c141ae77bea248eeb36687ac6835c9b2404f5475beb351c4d8539d552db4d88e933bb2bd5b73f165e62b130bb11aeff39928e69 hiredis-1.0.0.tar.gz"
diff --git a/main/hiredis/musl-test.patch b/main/hiredis/musl-test.patch
deleted file mode 100644
index 400f4a9d56d..00000000000
--- a/main/hiredis/musl-test.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- hiredis-0.14.0/test.c
-+++ hiredis-0.14.0_p/test.c
-@@ -439,6 +439,8 @@
- c = redisConnect((char*)"idontexist.test", 6379);
- test_cond(c->err == REDIS_ERR_OTHER &&
- (strcmp(c->errstr,"Name or service not known") == 0 ||
-+ strcmp(c->errstr,"Name does not resolve") == 0 ||
-+ strcmp(c->errstr,"Try again") == 0 ||
- strcmp(c->errstr,"Can't resolve: idontexist.test") == 0 ||
- strcmp(c->errstr,"nodename nor servname provided, or not known") == 0 ||
- strcmp(c->errstr,"No address associated with hostname") == 0 ||