aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-07 13:48:31 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-11-07 23:57:06 -0300
commit143783c1befd418a3d0f95c7f282c41ee0277c4b (patch)
tree0f03947def55b090a33367818e5688e0fb36fbe6
parentb1734d25da900358d7eebc4b4b469b70782ed9bc (diff)
community/py3-google-auth: upgrade to 1.7.0
-rw-r--r--community/py3-google-auth/APKBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/community/py3-google-auth/APKBUILD b/community/py3-google-auth/APKBUILD
index 1e5b61065ce..be711ff828c 100644
--- a/community/py3-google-auth/APKBUILD
+++ b/community/py3-google-auth/APKBUILD
@@ -2,17 +2,24 @@
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-google-auth
_pyname=google-auth
-pkgver=1.6.3
-pkgrel=2
+pkgver=1.7.0
+pkgrel=0
pkgdesc="Google authentication library for Python."
url="https://google-auth.readthedocs.io/en/latest/"
arch="noarch"
license="Apache-2.0"
-depends="python3 py3-cachetools py3-asn1-modules py3-setuptools py3-rsa py3-six"
+depends="
+ python3
+ py3-cachetools<3.2
+ py3-asn1-modules
+ py3-rsa<4.1
+ py3-setuptools
+ py3-six
+ "
checkdepends="py3-certifi py3-flask py3-oauth2client py3-pytest py3-pytest-cov
py3-pytest-localserver py3-requests py3-requests-oauthlib py3-urllib3
py3-cryptography"
-source="https://files.pythonhosted.org/packages/source/g/${_pyname}/${_pyname}-${pkgver}.tar.gz
+source="https://files.pythonhosted.org/packages/source/g/$_pyname/$_pyname-$pkgver.tar.gz
10-use-mock-from-standard-library.patch
"
@@ -30,5 +37,5 @@ check() {
pytest-3 # skips grpc tests
}
-sha512sums="47a3e9390428ffa58946c348d4e1a1bfe1290d6e06b75924bbacb37d5af929050690ef5c13820468de805646f4686c035b00dfe947c090d53568dd85d804af5e google-auth-1.6.3.tar.gz
+sha512sums="5cc14dba377e69270887bc36d70eb4a3934d0609646becd7830abceb3557f77008f84a8ade35170cbf3271b20f0978e2f099eef05db4afd93d3e8386d332b872 google-auth-1.7.0.tar.gz
4242765bce157f7e3ba42b668396d7629b78a389f82832960b689741c0f30f6a1a3d07e217b37c6c6515813b6a7783e1cc9308046bc38d9fcb0c596bf3f896ff 10-use-mock-from-standard-library.patch"