aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-05-22 07:05:33 +0000
committerpsykose <alice@ayaya.dev>2023-05-22 09:05:33 +0200
commit14c169bc016969b429ab834cddfae147cdb9a50a (patch)
treeec6c94d5a9a635bf84d242cfa05d07b1fa984775
parent64231530ff839fa28b1ccbefe0b588b489a53f2d (diff)
community/libtorrent-rasterbar: upgrade to 2.0.9
-rw-r--r--community/libtorrent-rasterbar/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/community/libtorrent-rasterbar/APKBUILD b/community/libtorrent-rasterbar/APKBUILD
index 00b733e8938..87e06621c64 100644
--- a/community/libtorrent-rasterbar/APKBUILD
+++ b/community/libtorrent-rasterbar/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: August Klein <amatcoder@gmail.com>
# Maintainer: psykose <alice@ayaya.dev>
pkgname=libtorrent-rasterbar
-pkgver=2.0.8
-pkgrel=3
+pkgver=2.0.9
+pkgrel=0
pkgdesc="Feature complete C++ bittorrent implementation"
url="https://www.rasterbar.com/products/libtorrent"
arch="all"
@@ -22,9 +22,9 @@ arm*|x86)
esac
build() {
- CXXFLAGS="$CXXFLAGS -flto=auto" \
+ CXXFLAGS="$CXXFLAGS -O2 -DNDEBUG -flto=auto" \
cmake -B build -G Ninja \
- -DCMAKE_BUILD_TYPE=MinSizeRel \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_CXX_STANDARD=17 \
-DCMAKE_INSTALL_PREFIX=/usr \
-Dbuild_tests="$(want_check && echo ON || echo OFF)" \
@@ -49,7 +49,7 @@ check() {
# flaky
tests_to_skip="$tests_to_skip|test_web_seed|test_url_seed|test_transfer|test_ssl"
- ctest -j2 --output-on-failure --test-dir build --exclude-regex "$tests_to_skip"
+ ctest -j4 --output-on-failure --test-dir build --exclude-regex "$tests_to_skip"
}
package() {
@@ -69,5 +69,5 @@ _py3() {
}
sha512sums="
-697988feae149876745097bedfbfb4cceae00ffe1cd4ba2063dcb93a8eee9e99344f772b8364e3df1986a50105e386e56b75fe362707d58ba3272139d9beb98f libtorrent-rasterbar-2.0.8.tar.gz
+c252dbe1e2a246769017b8a622bb3418527e2bc2615115ac2bff9662afb53759bc7b2cbf6657438c515ba6de0140fc1c388b340c48b3dd9f7e6202ec0df1aec7 libtorrent-rasterbar-2.0.9.tar.gz
"