aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-09-06 18:54:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-09-06 22:02:36 +0000
commit15171f825dc2d50b3310ab3087d181049c9e38bd (patch)
tree7ab7a3977abdfa708ad418e247e0ec56e1ae9d4a
parentbdf90357a27b37268998056c1ee2db9a04391961 (diff)
testing/sx: new aport
https://github.com/Earnestly/sx Simple alternative to xinit(1) and startx(1)
-rw-r--r--testing/sx/APKBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/testing/sx/APKBUILD b/testing/sx/APKBUILD
new file mode 100644
index 00000000000..658fdefa0f2
--- /dev/null
+++ b/testing/sx/APKBUILD
@@ -0,0 +1,19 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=sx
+pkgver=2.1.3
+pkgrel=0
+pkgdesc="Simple alternative to xinit(1) and startx(1)"
+options="!check" # No testsuite
+url="https://github.com/Earnestly/sx"
+arch="noarch"
+license="MIT"
+depends="xorg-server xauth"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Earnestly/sx/archive/$pkgver.tar.gz"
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha512sums="d945888cb164d85d7e1ae87f86a79d4ad3130b4656652d7def490b7846b6cb6ae3427e70e5bc311f4fc02bfc4e4e2ca6d618ba1a3a8f4c4cf4c4d212afbb4fb9 sx-2.1.3.tar.gz"