aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2021-02-23 00:58:14 +0100
committerTBK <tbk@jjtc.eu>2021-02-23 00:58:14 +0100
commit1522534fa2acf88bc9f48ae6aa58c641b8e52d42 (patch)
tree420acf71f9fe2385267ae49fc8d56bcd8b80959d
parent367b174ff8ce3a6704a9625612925353459235d5 (diff)
main/redis: security upgrade to 6.0.11
-rw-r--r--main/redis/APKBUILD10
-rw-r--r--main/redis/musl-zmalloc.patch23
2 files changed, 30 insertions, 3 deletions
diff --git a/main/redis/APKBUILD b/main/redis/APKBUILD
index a377ecab9eb..ad90f00b65e 100644
--- a/main/redis/APKBUILD
+++ b/main/redis/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Eivind Uggedal <eu@eju.no>
# Maintainer: TBK <alpine@jjtc.eu>
pkgname=redis
-pkgver=6.0.10
+pkgver=6.0.11
pkgrel=0
pkgdesc="Advanced key-value store"
url="https://redis.io/"
@@ -22,9 +22,12 @@ source="https://download.redis.io/releases/redis-$pkgver.tar.gz
$pkgname.confd
$pkgname-sentinel.initd
$pkgname.logrotate
+ musl-zmalloc.patch
"
# secfixes:
+# 6.0.11-r0:
+# - CVE-2021-21309
# 6.0.3-r0:
# - CVE-2020-14147
# 5.0.8-r0:
@@ -78,11 +81,12 @@ package() {
var/log/redis
}
-sha512sums="4ef60645316143db3c26c45e90c7dc629e15641313267fd732396212c67db9ebeb9e170d830599b2e143ad5135d1ef249b6fbc1fb4960f4cf857cfdb5c1470c8 redis-6.0.10.tar.gz
+sha512sums="13b08a98c2d89c2c53c9a80fe27acc98dbc9fd8e93d7baabed381c401877bd8672cf4472b17d8843edda674c41849859b90a722a3c99d99cfdc3769ae5e0a979 redis-6.0.11.tar.gz
006716439828981ab56bd8837e67d0a99a775e07a80a761903fa762c91571f5e5ffc1a99f0b518a944cbd8635609952ded838f342d5563345199f8e6e6579efd makefile-dont-duplicate-binary.patch
05a35246ee5136f10f1873eb91a267cf31d206d298ff8ac105efc501bbab7f44b50d4e4d92874701c81e105bd72a0ac73f5e810610de8e3769544e7c36a23748 redis.conf.patch
a5dc411c2bd7edf61400e29accb375275dd888fda72a8f7e3889be475010c695a22f536be818ef9441e47285c00b451966db924362a7f56806586078c9e3ff8c sentinel.conf.patch
f6dcdad1edd6b5fb6aa28ba774bfc8aba035f316695da261fb2ad291b76f00f177479f9d74434d06c26bd15f131edc9a2f55c9880758cf0987800d2031069738 redis.initd
6752e99df632b14d62a3266929e80c3d667be5c270e4f34e0dcf2b7f9b1754fe0ce9d4569fa413dbbe207e406ff2848a64e0c47629997536ae1d14ca84ebd56b redis.confd
e7a60a090df53eef05d58d73709f07536135a93efb34e48ad933e3859d3d1c0f476975a3232df18f57476bf7fc3b0548471e1c86445878457ac8507b3da71384 redis-sentinel.initd
-bf2def2077a989047e9bfff8a7f754bcdf96e020fd4a470f8967ee1fca601e11f044cfb3742f00e932cc013e0d0b199045d78c8878a0e529715c9f77786d353f redis.logrotate"
+bf2def2077a989047e9bfff8a7f754bcdf96e020fd4a470f8967ee1fca601e11f044cfb3742f00e932cc013e0d0b199045d78c8878a0e529715c9f77786d353f redis.logrotate
+e29fb36a43dbd991aa46f469d49f76d6c22354abf11abcfe91c2cc8254c0fe9f997e51288ca37e3d184b89b49cd9ffb42483f8ec35b99aee829bf3ee5b4c5163 musl-zmalloc.patch"
diff --git a/main/redis/musl-zmalloc.patch b/main/redis/musl-zmalloc.patch
new file mode 100644
index 00000000000..90e79d05a29
--- /dev/null
+++ b/main/redis/musl-zmalloc.patch
@@ -0,0 +1,23 @@
+Without this change it fails to compile, giving the following error:
+
+zmalloc.c:55:28: error: missing binary operator before token "("
+ #define PREFIX_SIZE (sizeof(size_t))
+ ^
+zmalloc.c:59:5: note: in expansion of macro 'PREFIX_SIZE'
+ #if PREFIX_SIZE > 0
+
+--- a/src/zmalloc.h
++++ b/src/zmalloc.h
+@@ -63,12 +63,10 @@
+
+ #ifndef ZMALLOC_LIB
+ #define ZMALLOC_LIB "libc"
+-#ifdef __GLIBC__
+ #include <malloc.h>
+ #define HAVE_MALLOC_SIZE 1
+ #define zmalloc_size(p) malloc_usable_size(p)
+ #endif
+-#endif
+
+ /* We can enable the Redis defrag capabilities only if we are using Jemalloc
+ * and the version used is our special version modified for Redis having