aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-09 02:58:20 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-31 06:26:00 +0000
commit170abcd465c3adb288034cd023d5ecced6217a1d (patch)
treecee3814758ed2c2d5f9f4f8df6b67b830fbf509f
parent2de70d40fbbcf1c7c8cf5ff3e7319de022c5ea10 (diff)
community/keepassx: purge, has alternative in keepassx
- Uses Qt4, Qt5 support but no release - Has community fork in the form of keepassxc
-rw-r--r--community/keepassx/APKBUILD42
-rw-r--r--community/keepassx/add_unistd.patch10
-rw-r--r--community/keepassx/musl-fixes.patch10
3 files changed, 0 insertions, 62 deletions
diff --git a/community/keepassx/APKBUILD b/community/keepassx/APKBUILD
deleted file mode 100644
index 791769133e0..00000000000
--- a/community/keepassx/APKBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Contributor: August Klein <amatcoder@gmail.com>
-# Maintainer: August Klein <amatcoder@gmail.com>
-pkgname=keepassx
-pkgver=2.0.3
-pkgrel=0
-pkgdesc="A password manager"
-url="http://www.keepassx.org"
-arch="all"
-license="GPL-2.0"
-makedepends="cmake qt-dev libxtst-dev libgcrypt-dev"
-source="https://www.keepassx.org/releases/${pkgver}/${pkgname}-${pkgver}.tar.gz
- musl-fixes.patch
- "
-builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$builddir"
- mkdir build
- default_prepare
-}
-
-build() {
- cd "$builddir"/build
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib \
- -DCMAKE_BUILD_TYPE=Release ..
- make
-}
-
-check() {
- cd "$builddir"/build
- make test
-}
-
-package() {
- cd "$builddir"/build
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="bf1a4ffa49fc4a6b7a27e6292981c9c13920712b4cd86759a99976f7e0593a243ea14575c57d664ba7e55d2449b5d83bc3d43a64a9a6972335e52234da79d773 keepassx-2.0.3.tar.gz
-f393ce341eb6941bfb808369f076585536802284ab7ee6034a26284dc70bbf168f4a89dc676357334e30a527a5593cb1b20cabb4e699ae806ca9e229ac6cffdd musl-fixes.patch"
diff --git a/community/keepassx/add_unistd.patch b/community/keepassx/add_unistd.patch
deleted file mode 100644
index f7d08027b2d..00000000000
--- a/community/keepassx/add_unistd.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/lib/random.cpp
-+++ b/src/lib/random.cpp
-@@ -18,6 +18,7 @@
- * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
- ***************************************************************************/
-
-+#include <unistd.h>
- #include "random.h"
-
-
diff --git a/community/keepassx/musl-fixes.patch b/community/keepassx/musl-fixes.patch
deleted file mode 100644
index 5afb7ed7c8f..00000000000
--- a/community/keepassx/musl-fixes.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/core/qlockfile_unix.cpp.orig 2015-07-19 00:41:35.000000000 +0200
-+++ b/src/core/qlockfile_unix.cpp 2015-07-21 20:01:02.607722077 +0200
-@@ -39,6 +39,7 @@
- #include <QDebug>
- #include <QDateTime>
-
-+#include <fcntl.h>
- #include <sys/file.h> // flock
- #include <sys/types.h> // kill
- #include <signal.h> // kill